AWS Route 53 DNS errors after moving from LightSail to EC2


I have a website called . It used to run on LightSail but I decided to move to EC2 and stop depending on burstable CPU. When I did that, I deleted all my records in LightSail networking. I deleted the static IP and DNS zone.

I recreated an Elastic IP address that I associated to the EC2 engine, my website connection works well based on the IP address. Then, I recreated a new hosted zone and rewrote the DNS associated to I also created the A record for the elastic IP address. After 48 hours, I am still not able to access my website with my registered domain name. I also tried with the IP address of the EC2 VM but no luck.

At this point, I have tried everything I could think of and I am still not able to make it work. I get an error like the DNS server is not responding but I think my DNS servers match with the hostname. I also checked here ( Some parts of the world have the right DNS. I am a bit lost.

Everything was working very well before. Thank you for your help.

asked 2 years ago143 views
1 Answer

I had to change my registered domain and not my hosted zone dns.

answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions