By using AWS re:Post, you agree to the Terms of Use

getting 502 bad gateway errors every time I turn on ec2 instance

0

I am currently building a web application on an ec2 instance. All of the code is stored within the server. When I type in the ec2 instance's ip address (35.167.110.26), I get a 502 bad gateway error. Although the server itself may have turned on, I still get a 502 bad gateway error because the code relies on a python import called flask. To enable flask, I have to manually type in "sudo service nginx restart" and "sudo service gunicorn3" restart within the /etc/nginx/sites-available directory. Once I type in those commands, the website works. Is there a way that I can enable these commands to run automatically every time I turn on the ec2 instance?

2 Answers
2

Use User-data to introduce the interested commands at launch. The following link should help: https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/user-data.html

profile picture
answered a month ago
1

Hello,

You can use the following commands to add nginx and gunicorn3 to start up:

sudo systemctl enable nginx
sudo systemctl enable gunicorn3
profile picture
MODERATOR
answered a month ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions