By using AWS re:Post, you agree to the Terms of Use
/why my s3 policy generator dosen't work?/

why my s3 policy generator dosen't work?

1

When i try to generate my s3 policy, Add statement dosen't work with messaege "Resource field is not valid. You must enter a valid ARN." even if i copied my arn by my bucket and add "/". principal is "".

Anyone can help?

asked 15 days ago531 views
2 Answers
0

An answer providing a decent workaround on my post regarding the same issue:

"Hi,

I understand that you are having an error with creating an s3 bucket policy using the AWS policy generator. I did replicate and received the same error.

As a workaround:

I inserted a * in the ARN section and generated the policy.

I, thereafter, replaced the * with my ARN once it has been generated.

Please find the attached ARN Format documentation[1].

I hope this helps

Resources:-

[1] https://docs.aws.amazon.com/general/latest/gr/aws-arns-and-namespaces.html. "

Thanks to Asisipho for the answer https://repost.aws/community/users/US0lvBJf90StOho6DSWkZivQ

answered 12 days ago
0

Hello,

I understand that you are experiencing the error below when attempting to generate s3 policy: "Resource field is not valid. You must enter a valid ARN."

I replicated the issue from my end and I got the same error as yours. I believe that this is a bug from S3 regarding the feature. Therefore, I would suggest that you open a ticket with the S3 team for further assistance in this regard[1]. In the meantime, you may consider creating the policy manually, if you face any challenges I am happy to assist. Feel free to share your use case.

Reference:

[1] https://t.corp.amazon.com/create or https://us-east-1.console.aws.amazon.com/support/home

I hope the information above is helpful.

answered 15 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions