By using AWS re:Post, you agree to the Terms of Use
/Static website hosted in S3 using Cloudfront and Route 53 is down/

Static website hosted in S3 using Cloudfront and Route 53 is down

0

My domain name is "bijusharman.com" . It was working until yesterday. I updated the html and css files in my S3 bucket today and started getting this problem. I created an invalidation record in cloudfront to make the changes immediately effective.

Dig on the domain alone gives : SERVFAIL Dig on the domain with one of NS present in hosted section of Route 53 gives : REFUSED.

After searching in google I realized that NS names should be consistent in both "Hosted Zones" section and"Registered Domain" section ; they were different. I updated the value in "Registered Domain" section with that of "Hosted Zones" section.

My queries :

  1. All the while it was working fine why this problem ( if ever it si due to NS inconsistency) came now?

  2. Will I have to wait until 2 days for the changes to be effective? Is there a quick way to get it resolved?

Thanks Biju

4 Answers
0
Accepted Answer

In the second case, you don't need to wait 2 days, it should be available a lot faster.

In the first question, I have no idea why it worked. If the NS are different, then your HostedZone can't manage your domain, because domain is pointing to different NameServers.

answered 5 months ago
  • Thanks for the answer.

    For Point2, should I just wait or is there anything I can do to make it fast?

  • Unfortunately, you need to wait, but last time when I was changing it, it was ready in a few hours.

0

I'm writing new answer so it will send notification :)

Please check once again Route53 Hosted Zone and Domain if the NS records are the same.

It's very important that in Hosted Zone you need .(dot) after each of the NS records. Please verify it as well.

answered 4 months ago
  • Sorry not to update here. My issue was resolved a day ago. 1. In Hosted Zone , there are two sections : Details and Records. All the while I was trying to keep Records and Domain registrar in synch. After keeping these two ( Records and Domain registrar) same as "Hosted zone details" , the problem got resolved. 2. To fasten up the updates, I made the TTL of NS record an hour. After WHOIS reflected my changes, I reverted back the TTL to two days. 3. I remember seeing the '.' at the end of NS some where/some time. Now if I see ,the 3 places are not having '.' as suffix and still everything works fine.

  • Perfect! Good that you fix it :)

0

It is now more than 48 hours, my website is still down. There is no change in DIG responses. If I give it against one of my NS, I still get REFUSED error.

answered 5 months ago
  • then I think you must do something wrong. Please check it once again if the NS records in Hosted Zone are the same as in the Domain in Route 53

0

This is a tough one to diagnose remotely but this page could provide some help? https://docs.aws.amazon.com/Route53/latest/DeveloperGuide/domain-name-servers-glue-records.html

answered 4 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions