By using AWS re:Post, you agree to the Terms of Use

AWS Config - OrganizationConformancePack fails with NoAvailableConfigurationRecorderException

0

We are trying to deploy Organization Conformance Packs via CloudFormation. But the deployment always fails with the below exception: NoAvailableConfigurationRecorderException in 1 account(s)

AWS Config recorder ist configured in the Management Account and we have completed the Prerequisites for Organization Conformance Packs. Trusted service access for AWS Config is enabled in our Organization by creating a multi-account aggregator and adding the organization. Our Cloud Landing Zone is created using Control Tower. Also we've followed this blog post to try the same with a delegated Administrator account. Last but not least we've given the config recorder role admin access and excluded all account except the Management Account in our template. Still no luck. Anyone having an idea how to solve this issue?

1 Answers
0
Accepted Answer

Problem is solved. I've found out that one legacy member account which is not enrolled in Control Tower doesn't have Config activated. I've used CLI to deploy and troubleshoot it.

answered 2 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions