Can't create DMS Instance with The Replication Subnet Group already exists

0

Hello!
I've got 'SYSTEM ERROR MESSAGE:The Replication Subnet Group 'default-vpc-c2c6c6a5' already exists.' when I tried to create a new DMS Instance. I tried to recreate IAM role dms-vpc-role, tried to create another VPC. I'm using almost fresh AWS account so I don't think that I have already cracked it.

Edited by: ZnoWM on Feb 16, 2020 5:34 PM

ZnoWM
asked 4 years ago3818 views
2 Answers
1

Hi

I just had the same problem when creating a new replication instance in AWS console. First time I hit the create button I had another error, I fixed it, hit create button again and then I had the same error 'Subnet Group already exists'.

I went to the 'Subnet groups' page (in DMS) and manually deleted the existing subnet group. Then the creation went just fine.

Seems like the subnet group creation is not rolled back when an error occurs.

maso
answered 4 years ago
0

Maso's solution worked for me too.

kyorgy
answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions