By using AWS re:Post, you agree to the Terms of Use

unable to start cloudshell

3

Unable to start the environment. To retry, refresh the browser or restart by selecting Actions, Restart AWS CloudShell. I am getting that error even after following the instruction and I am using ohio region. I alread tried using other regions with cloudshell like tokyo but still facing this issue. I am also using my root account and still the same issue.

4 Answers
0

Make sure there are no Service Control Policies blocking the account from using CloudShell. The policy simulator may help narrow down what is blocking if it is a permissions issue. https://policysim.aws.amazon.com/

profile picture
EXPERT
answered 7 months ago
  • Policy simulator shows I should have access to CloudShell but I don't have.

0

The two regions you mentioned are supported refer to AWS CloudShell endpoints and quotas. If this was a permission error I would expect to see a different error. To be sure check that your current permissions includes necessary permissions, for example, AWSCloudShellFullAccess.

This could be browser related. CloudShell supports below so check that your browser meets these requirements

  • Google Chrome
    • Latest three major versions
  • Mozilla Firefox
    • Latest three major versions
  • Microsoft Edge
    • Latest three major versions
  • Apple Safari for macOS
    • Latest two major versions
answered 7 months ago
0

So i was able to resolve this issue with the help of AWS repost user @Maulik_Makadiya. Few things to try to create CloudShell environment:

  • Time Synchronization: Make sure Your machine time is accurate. It means its correct based on world time. did you try from another machine to see if its working there? may be any time sync related issue?

  • Check in different regions..

  • check AWSCloudShellFullAccess policy to ensure it has below JSON data.

{
    "Version": "2012-10-17",
    "Statement": [
        {
            "Action": [
                "cloudshell:*"
            ],
            "Effect": "Allow",
            "Resource": "*"
        }
    ]
}

Your account must be verified before you can add new CloudFront resources. To verify your account, please contact AWS Support (https://console.aws.amazon.com/support/home#/ ) and include this error message.

Click the support link

  1. Navigate to:

Support / New case / Service limit increase

  1. Limit type:

CloudFront Distributions

  1. In Requests select:

Limit: Web Distributions per Account New limit value: <TYPE_YOUR_NEW_VALUE_HERE>

MY CASE: In my case, I had 2 distributions, wanted to create 3rd, but couldn't. So I have put as <TYPE_YOUR_NEW_VALUE_HERE> a number 10.

Note: If nothing works choose last option as your last resort to confirm your account is verified.

hope it helps.

answered 7 months ago
0

I'm having the same issue even though I'm using Root User and I don't think it's a browser problem because another root user can be used normally. I tried to simulate and the permission column said allowed both CloudShell Create & StartEnvironment. How should I do?

Thank you very much.

answered 4 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions