Sagemaker requirements.txt unable to find certain packages

0

Hi,

I'm trying to run a sagemaker job on p3.2xlarge instance using the PyTorch estimator. My script has dependencies on several packages (possibly not pre-installed on the instance) for which I have a requirements.txt file. After loading the instance, it installs several packages but the job fails with following error:

sagemaker-training-toolkit ERROR InstallRequirementsError: Command "/opt/conda/bin/python3.6 -m pip install -r requirements.txt" ERROR: Could not find a version that satisfies the requirement scikit_image==0.18.3 ERROR: No matching distribution found for scikit_image==0.18.3

It fails for other packages too, like h5py, numpy etc.

Any help is greatly appreciated.

Thank you, Aditya

  • Is your job failing to find any dependencies? Or successfully installing some but failing on some specific libraries? Since if it's not working with any at all, could suggest something like a networking problem (for example not able to reach PyPI/package repository at all).

  • Hi Alex, my job is able to install a few and fails for few others, but those packages (requirements.txt) can be easily installed on my local system without any issue.

  • This is the output from the logs:

    2022-04-13 18:21:13,404 sagemaker-training-toolkit INFO Installing dependencies from requirements.txt: /opt/conda/bin/python3.6 -m pip install -r requirements.txt Collecting beautifulsoup4==4.11.1 Downloading beautifulsoup4-4.11.1-py3-none-any.whl (128 kB) Collecting dominate==2.6.0 Downloading dominate-2.6.0-py2.py3-none-any.whl (29 kB) Collecting opencv_python==4.5.5.62 Downloading opencv_python-4.5.5.62-cp36-abi3-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (60.4 MB) ERROR: Could not find a version that satisfies the requirement scikit_image==0.18.3 ERROR: No matching distribution found for scikit_image==0.18.3 2022-04-13 18:21:16,658 sagemaker-training-toolkit ERROR InstallRequirementsError: Command "/opt/conda/bin/python3.6 -m pip install -r requirements.txt" ERROR: Could not find a version that satisfies the requirement scikit_image==0.18.3 ERROR: No matching distribution found for scikit_image==0.18.3

asked 2 years ago1135 views
1 Answer
0

Hello,

Thank you for using Amazon SageMaker.

Usually this kind of error is occurred due version mismatch or missing dependencies. As you have mentioned that it worked locally on your system without any issue, we would like to dive deep into this issue for which we will required your script and requirement.txt file and sharing those files with us will help us identify what is the root cause of this issue and help you overcome this issue. Sharing any files on this medium is not encourage, so I recommend you to open a case with SageMaker Premium Support team so that you can share above mentioned details securely.

Open a support case with AWS using the link:

https://console.aws.amazon.com/support/home?#/case/create

AWS
SUPPORT ENGINEER
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions