Using Secret Manager for password bug?

0

I'm trying to use secrets manager to generate the password for DocumentDB and I'm stuck. I've managed to simplify to the below. It doesn't seem to matter if I generate it or not actually, when hard coded to a short password I still get the error.

      MasterUserPassword:         '{{resolve:secretsmanager:ab:SecretString}}'
Property validation failure: [Length of value {{{resolve:secretsmanager:ab:SecretString}}} for property {/MasterUserPassword} is greater than maximum allowed length {41}]

However the below works:

      MasterUserPassword:         '{{resolve:secretsmanager:a:SecretString}}'

Anyone else tried this or hit this issue or managed to get it working?
Looks like it's doing the 41 digit check on the pre-resolved string, not the actual password

gmc77
asked 4 years ago28 views
1 Answer
0

There was a bug in Cloudformation passing dynamic references, however it was fixed 3 years ago.

Mihai A
answered a month ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions