By using AWS re:Post, you agree to the Terms of Use

AWS Data Pipeline Error : Access denied for user 'admin'@'172.31.89.157' (using password: YES)

0

**Transfer data from RDS MySQL to S3 bucket **

I set up a data pipeline to transfer data from RDS Mysql to S3 Bucket, where before thet I set up the RDS mysql database with username and password. (IAM authentication enabled)

It seems that EC2 that lunched by data pipeline can not access the database. error message : ( Access denied for user 'admin'@'172.31.89.157' (using password: YES) )

Noting that I tried to create new user with awsauthentication plugin, and used the master password, but that is not working, it give the same error.

Can you advise guys! Thanks for your answers in advance!

1 Answer
1
Accepted Answer

What are node type are you using MySqlDataNode or SqlDataNode ? As you have enabled IAM authentication Granting the IAM role in MYSQL would be useful as IAM authentication is taking precedence over the master user and use the same IAM user for Ec2Resource.

  • mysql> CREATE USER RDSConnect IDENTIFIED WITH AWSAuthenticationPlugin AS 'RDS';
  • mysql> GRANT ALL ON %.* TO RDSConnect@%;
  • mysql> select * from mysql.user where user='RDSConnect'\G

Also check GRANT has allowed connection from master user and password from any hosts like % for grant. were you able to the connect from EC2 instance using mysql client ?

some useful links:- https://kumo-knowledge-ui-iad-prod.amazon.com/view/article_12180

answered 6 months ago
  • Thanks for your comment, I can not open the below link below!

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions