By using AWS re:Post, you agree to the Terms of Use

Can not turn off Performance Insights

0

The purpose is to delete an old database (Size: db.m5.xlarge; DB Engine: 8.0.16 Version).

First, we tried to disable Delete Protection, but it shows an error message as below:


We're sorry, your request to modify DB instance prod-uptrade-db has failed. Performance Insights not supported for this configuration, please disable this feature.


Therefore, we tried to turn off Performance Insights by following this article (https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/USER_PerfInsights.Enabling.html). However, after we clicked Modify, we can't find the Performance Insights section anywhere. Anyone can help? Thank you.

asked 5 months ago72 views
1 Answer
0
Accepted Answer

I am not sure if you are running on RDS MySQL / MariaDB or Aurora MySQL. But there are certain instance types on which you cannot support Performance Insights.

RDS MySQL: [+] https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/USER_PerfInsights.Overview.Engines.html Performance Insights isn't supported for the following instance classes:

  • db.t2.micro
  • db.t2.small
  • db.t3.micro
  • db.t3.small

Aurora MySQL: [+] https://docs.aws.amazon.com/AmazonRDS/latest/AuroraUserGuide/USER_PerfInsights.Overview.Engines.html Performance Insights isn't supported for the following instance classes:

  • db.t2 – Not supported
  • db.t3 – Not supported
  • db.t4g – Supported only for 2.10.1 and higher 2 versions (compatible with MySQL 5.7) and all 3 versions (compatible with MySQL 8.0)
answered 5 months ago
  • Thank you for your reply. Our version is RDS MySQL 8.0.16, which doesn't support Performance Insights, but we don't know how it was enabled. We changed to a MySQL version number that supports Performance Insights, and then we were able to disable the feature and eventually delete the database.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions