By using AWS re:Post, you agree to the Terms of Use

Athena ODBC Connector for Power BI

2

I have two catalogs in Athena - AwsDataCatalog and another named 'rds_catalog'. The 'rds_catalog' has been created to connect to RDS database instance using the Amazon Athena Federated Query connectors. I have the Simba Athena ODBC driver installed on my machine and a 'User' DSN created.

I have ensured the second catalog has been setup correctly.

When i connect to Athena using Power BI and the ODBC DSN, I see only the 'AwsDataCatalog' listed. The Other Catalog does not show up. This is so even when i set the schema to 'rds_catalog'. Makes me wonder if the driver is designed to show only the 'AwsDataCatalog' or if this is a power BI issue or something wrong that i am doing.

Appreciate any help on this issue.

3 Answers
1

Go to OBDC data source configurations and change the Metadata Retrieval Method to "Proxy API" from "Auto".

answered 3 months ago
EXPERT
reviewed 13 days ago
0

I'm having this exact same issue. While the workaround that AWS-User-0620047 mentioned is sufficient for their use case, I need the DB's/tables of the 'rds_catalog' (in this example) to be displayed in the Power BI console. That way, users can see all of the different DB's/tables instead of needing to know exactly what they're querying for. So I'll echo the initial post... Is the driver designed to show only the 'AwsDataCatalog'? Or would this be an issue with power BI only being capable of displaying the AwsDataCatalog?

answered 5 months ago
  • Hi,

    This behavior is not limited to Power BI - I tried with Microsoft Excel too, seeing the same behavior. I believe it could be either the Driver's limitation OR something to do with the Driver-AWS interaction.

    Regards

  • Go to OBDC data source configurations and change the Metadata Retrieval Method to "Proxy API" from "Auto".

0

Hi,

As per the doc at page 91, you can use the Catalog option in your DSN.

Hope this helps

answered 7 months ago
  • Thank you for your response, Abdel.

    When I created the DSN entry, I did specify the other catalog's name against 'catalog' and the relevant schema name against 'Schema'. Power BI desktop client does not show this catalog in the 'navigator' window. Only the default catalog (AwsDataCAtalog) is listed.

    I found a workaround for this issue ... on the 'From ODBC' window where one is presented and prompted to select 'DSN', there's also an 'Advanced options' selection. Expand the 'Advanced options' selection pane, and fetch desired data by giving an SQL query in the 'SQL Statement' box. Doing it this way, I was able to get data under the other catalog.

    Cheers

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions