SSM agent syslog errors

0

New EC2 Ubuntu 18.04 AMI with IAM role AmazonSSMManagedInstanceCore attached. Seeing the following in syslog:

Aug  2 15:42:00 www amazon-ssm-agent.amazon-ssm-agent\[929]: Error occurred fetching the seelog config file path:  open /etc/amazon/ssm/seelog.xml: no such file or directory  
Aug  2 15:42:00 www amazon-ssm-agent.amazon-ssm-agent\[929]: 2019-08-02 15:42:00 ERROR Error adding the directory to watcher: no such file or directory  

Should there be an /etc/amazon/ directory in the system? There currently isn't. Have tried rebooting system and restarting amazon-ssm-agent.

asked 5 years ago1906 views
1 Answer
0

Hi,
I solved doing these steps

#mkdir /tmp/ssm
#systemctl stop snap.amazon-ssm-agent.amazon-ssm-agent.service
#systemctl start snap.amazon-ssm-agent.amazon-ssm-agent.service

And check you have activity in the log file tail -f /var/log/amazon/ssm/amazon-ssm-agent.log

If you are not sure, using console go to AWS System Manager --> Managed Instances and check it.

Regards.

answered 4 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions