By using AWS re:Post, you agree to the Terms of Use

Running Hyperledger Besu instance on EC2

0

I'm trying to start a node for a private implementation of Besu on my EC2 instance. However, every time I try to start the node, it throws a java.net.ConnectException immediately on start. There is no message given, no cause, just throws the exception immediately and dies.

I've checked the security groups, and all the necessary ports are open. I tried it with and without UFW and no success. I also tried using ports that are already standard defined but not commonly used UDP/TCP ports, and that did not work either. It runs successfully in our local dev environment, so I know the difference is environmental and not a code issue, but I'm not sure where else to look.

The Java version is the same, the compiled jars are the same, and I've tried everything I can think of with regards to opening ports on the EC2 instance.

1 Answer
-1

Hello,

If the server listens on port 1099 then the port you use to connect the stub is random so you either have to open all TCP ports in the security group of AWS.

OR, you can specify the port while constructing or exporting which is recommended.

Hope this helps.

SUPPORT ENGINEER
answered 12 days ago
  • I specify the port to 30303 as well as 8545-8546. I also tried opening all ports, and that did not succeed either. I tried most of the obvious solutions, and they did not work. I tried using a standard port and it did not work.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions