By using AWS re:Post, you agree to the Terms of Use

Creating AMI from snapshot won't accept paravirtual virtualization type

0

I have a snapshot I need to restore that was created the day before. I typically do this by creating an image from the snapshot and then launching an ec2 from the AMI using a launch template. The ec2 that the snapshot is created from has a virtualization type of paravirtual. When I create the image I select paravirtual. However, the image always creates with a virtualization type of hvm. Is there any reason why this would be happening? (I have tried older snapshots as well as with snapshots from other instances, but this keeps happening).

  • I don't have any paravirtual instances, but according to the documentation, you have to specify the Kernel ID that matches the source OS. You may also have to enter a RAM Disk ID if you are using that feature. Are you specifying those options?

asked 22 days ago15 views
2 Answers
0
Accepted Answer

I also tried: ec2-register -n pvami -s snap-0ffe4a3cb9932b167 --virtualization-type paravirtual to see if I could force the ami to paravirtual, but this didn't work either. The ami is still listed as hvm.

answered 21 days ago
  • You need to specify --kernel-id <kernel> on aws ec2 register-image, but I don't know what your kernel ID is. Try uname -a on the command line of the original instance

  • Thank you! That was it!

0

Thanks for getting back to me, Rodney. I checked and when I create the AMI I cannot select a kernel. It just says it is going to use the default. I never selected one before, honestly. I've checked a few other snapshots, both from the same ec2 I am using and others from different ec2's (All using paravirtual).

answered 21 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions