By using AWS re:Post, you agree to the Terms of Use

Getting a "SINGLE_BUILD_CONTAINER_DEAD" error with a custom Docker image

0

We need to use a custom Docker image for our CodeBuild processes, so I created one on my M1 MacBook Pro and uploaded it to AWS ECR. However, whenever I tried to use it in CodeBuild project I received the following error:

SINGLE_BUILD_CONTAINER_DEAD: Build container found dead before completing the build. Build container died because it was out of memory, or the Docker image is not supported

I looked for more information on the error but wasn't able to find anything on-line.

profile picture
asked 5 months ago414 views
1 Answer
0
Accepted Answer

I found out what the problem was and thought I would document it here to help others that might be in the same boat. See, when we originally developed this process I was using an Intel MacBook Pro and everything worked fine.

However, as I noted in the question, my current machine is an M1 (ARM) system. So, when I built the Docker images locally and uploaded them to ECR, it caused CodeBuild to fail with that "SINGLE_BUILD_CONTAINER_DEAD" error. I solved my "problem" by having CodeBuild create the Docker image for me and uploading that to ECR.

NOTE: I'm sure that it's possible to get Docker on an M1 machine to create x86 images, but I'm not familiar enough with Docker to make that happen. If you know the magic incantations to make that happen, please let a comment below.

profile picture
answered 5 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions