Codecatalyst spaces in AWS Account - request was not authorized

0

I logged into one of my accounts and tried to create a space via codecatalyst. There were some issues so I removed the space from codecatalyst, and from the account.

Now when I log into the AWS Console and choose Amazon CodeCatalyst > Spaces, I get a message The request was not authorized.

I've checked the IAM Role and it is using the AWSAdministrator permissions policy which allows all CodeCatalyst API calls.

If I now try and create a new space under the account, at the verify stage I always get Invalid Token Enter image description here

profile picture
asked 2 years ago455 views
2 Answers
1

Hi Simon,

I'm so sorry you ran into this issue. I've alerted our team on the issue. They are looking into it now. In the meantime could you please check if you are on the right account? The token can only be accepted by the account that is being verified

AWS
EXPERT
answered 2 years ago
  • Hi, we couldn't replicate the issue. But we have noticed invalid token issues when the user tries to validate their token on a different AWS account instead of the one that they were attempting to connect to the space. could you please confirm if you were on the right AWS account when you tried to verify the token?

0

Simon - check if an SCP or anything else prohibits you from using us-west-2 - that's what happened to me last week and you don't directly get that form the message of the expired token. Took me a few days to figure it out :-)

As CodeCatalyst is in that region, the "link" also needs to happen within that region...

profile picture
answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions