I am trying to syc my ec2 instance with aws time sync service but am getting the error below

0

chronyd[XXXXX]: Could not add source 169.254.169.123 I have tried adding: server 169.254.169.123 prefer iburst as well as a different try adding: server 169.254.169.123 prefer iburst minpoll 4 maxpoll 4 pool time.aws.com iburst

asked a year ago1564 views
2 Answers
0

try this:

  • Make sure that your instance is able to connect to the internet and that there are no network connectivity issues that might be preventing it from reaching the time source.
  • Ensure that your instance's security group allows outbound traffic to the internet on port 123 (UDP), which is used for NTP (Network Time Protocol) traffic.
answered a year ago
  • Instance is able to connect to the internet, and the security group allows outbound traffic to the internet across all ports

0

Hi. EC2 can connect Time Sync Service without Internet access or setting of sg and network acl. By the way are you using Amazon Linux/Linux2?If so those AMIs synchronize with the Amazon Time Sync Service by default.If not you can find how to setup cronyd by follwing link.

The Amazon Time Sync Service is available through NTP at the 169.254.169.123 IPv4 address or the fd00:ec2::123 IPv6 address. The IPv6 address is only accessible on Instances built on the Nitro System. Your instance does not require access to the internet, and you do not have to configure your security group rules or your network ACL rules to allow access. The latest versions of Amazon Linux 2 and Amazon Linux AMIs synchronize with the Amazon Time Sync Service by default. If not you can find how to setup cronyd by follwing link.

https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/set-time.html

profile picture
EXPERT
answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions