By using AWS re:Post, you agree to the Terms of Use

AWS Sns Publish method is not working when application deployed using docker container

0

0

I have wrote java code[Can be found in Screen short] to publish message to aws sns. Below is my issue. 1.When I run the code using command line [cmd: java -jar snsDemo.jar] I am able to publish message to sns Topic 2.But when I hit using the same code via api call which is deployed using docker container. I am not able to publish the message to topic neither I am getting any kind of error.

Issue is same code is working when I run using command line but it is not working when I hit via Api call

Note:Code execution is going till System.out.println(snsClient);[See image attachment] and getting stuck at publish method

image Link: https://i.stack.imgur.com/XJBeb.png

No Answers

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions