By using AWS re:Post, you agree to the Terms of Use

Packaging Java Lamba using CDK is failing in Code Build

0

I am following this blog - https://aws.amazon.com/blogs/opensource/packaging-and-deploying-aws-lambda-functions-written-in-java-with-aws-cloud-development-kit/ to create the java lambda using CDK. But when I pushed the changes and it is failing in code build with the below error. The "cdk synth" worked in my local machine. Can some one give any insights on this issue ?

Bundling asset TestStack/test/LambdaStack/LambdaFunction/Code/Stage...
[ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:3.0.0:java (default-cli) on project test: An exception occured while executing the Java class. Failed to bundle asset TestStack/test/LambdaStack/LambdaFunction/Code/Stage, bundle output is located at /codebuild/output/src940121800/src/cdk.out/asset.593cf75a4cb232e162ae4760eddc8336106322f580119285c2b8f0df0c517874-error: Error: docker exited with status 125
1 Answer
0

I enabled the privileged option in the environment variable in code build and also added "dockerEnabledForSynth(true)" in CodePipeline construct. Then it ran as expected.

I think the mvn build script is trying to download the maven libraries, but it got failed resulted in error. The moment I enabled the privileged option, it worked. I think, this is nothing to do with Docker but not sure.

answered 6 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions