Multi-AZ DB Cluster Parameter Group Updating Not Working


Note: Aurora Clusters are not the same as Multi-AZ DB Clusters. In my situation I am not using Aurora.

I have been having no success trying the change my Multi-AZ DB Cluster parameter group in the region N. Virginia, so I decided to give it a try in the Ohio region. What I noticed is a difference in the UI for inspecting a writer/reader node in the cluster.

Virginia Region:

Shows writer node with default parameter group

Ohio Region: Shows writer node without displaying parameter group

This difference in UI between the regions is strange and I feel it may be some sort of bug. With Multi-AZ DB Clusters the writer/reader nodes are supposed to get their parameter group configuration from the "cluster" and so not showing it in the Ohio version makes sense because it's based on the cluster.

The Virginia version is showing the writer/reader parameter group as if it IS the cluster node (by displaying way more information than the Ohio region version). This doesn't make sense and even when I do change the cluster's parameter group when modifying the cluster itself, the writer/reader nodes DO NOT change their parameter group. They stay the same using the default: default:mysql-8-0.

Even creating the cluster with a custom parameter group from the very beginning, the writer/reader nodes do no accept it, they keep: default:mysql-8-0.

This is very confusing and not in-line with what the documentation describes when dealing with this functionality.

2 Answers

As for the UI question: did you try to refresh the page? I am unable to reproduce what you've described.

On the console you can click on "Modify" and change the cluster parameter group. Also to reboot the cluster, you can click on "actions" and select "Reboot"

answered 9 months ago
  • Everything you suggested in your answer did not work. Some actions using the UI just don't take effect and require our team to use the CLI tool instead. Which does work. Even after upgrading the RDS cluster with a bigger volume, the UI panel displays a status of "Storage-full" in perpetuity.


I was able to get the parameter group changed and verified using the AWS RDS CLI tool. Once the change was made via the CLI, the UI still DID NOT reflect the changes.

I am going to sum this up to a UI/Javascript bug in the AWS console.

How to do it via CLI:

aws rds modify-db-cluster --db-cluster-identifier {your-cluster-id} --db-cluster-parameter-group-name {your-cluster-parameter-group-id} --apply-immediately

Then restart cluster (also something I cannot do in the UI)

aws rds reboot-db-cluster --db-cluster-identifier {your-cluster-id}


CLI tool install:

CLI tool configuration:

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions