AWS_PLATFORM error

0

Hello, please help for the below issue.
I meet the AWS_PLATFORM error for building a project on AWS machine, please see below error:

ERROR: [v++ 60-1258] No valid platform was found that matches 'AWS_PLATFORM'. Please make sure that the platform is specified correctly, and the platform has the right version number. The platform repo paths are:
/home/ubuntu/aws/aws-fpga/Vitis/aws_platform/xilinx_aws-vu9p-f1_shell-v04261818_201920_2
/tools/Xilinx/Vitis/2019.2/platforms
The valid platforms found from the above repo paths are:
/home/ubuntu/aws/aws-fpga/Vitis/aws_platform/xilinx_aws-vu9p-f1_shell-v04261818_201920_2/xilinx_aws-vu9p-f1_shell-v04261818_201920_2.xpfm
/tools/Xilinx/Vitis/2019.2/platforms/xcvc1902_fixed/xcvc1902_fixed.xpfm

when I check the ENV I get:
$ echo $PLATFORM_REPO_PATHS
/home/ubuntu/aws/aws-fpga/Vitis/aws_platform/xilinx_aws-vu9p-f1_shell-v04261818_201920_2

$ echo $AWS_PLATFORM
/home/ubuntu/aws/aws-fpga/Vitis/aws_platform/xilinx_aws-vu9p-f1_shell-v04261818_201920_2/xilinx_aws-vu9p-f1_shell-v04261818_201920_2.xpfm

So where is the problem? I already set the correct AWS_PLATFORM name and the correct PLATFORM_REPO_PATHS. but Vivado still complain that No valid platform was found that matches 'AWS_PLATFORM'.

asked 4 years ago257 views
2 Answers
0
Accepted Answer

I suspect you forgot the $ in front of AWS_PLATFORM when running you make command.
The proper command should be:
make check TARGET=hw DEVICE=$AWS_PLATFORM

answered 4 years ago
0

OK I just find a solution, if I use the below command to build, there will be no error report, build can be done..
make check TARGET=hw DEVICE=xilinx_aws-vu9p-f1_shell-v04261818_201920_2

So the AWS_PLATFORM (which is generated by sourcing vitis_setup.sh I think) is not correct?

answered 4 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions