logs in Fargate: /usr/sbin/apache2ctl: 99: ulimit: error setting limit (Operation not permitted)

0

I'm trying to start apache 2.4.41 x86_64 in a container in a Fargate service but it's failing to start. The errors in the Service logs are: /usr/sbin/apache2ctl: 99: ulimit: error setting limit (Operation not permitted)

Setting ulimit failed. See README.Debian for more information.

When I build and run from the Dockerfile on my local machine, the container builds and runs fine and the apache server starts up OK so I think it's something to do with Fargate/Task/Container settings but not sure which. I dug up an article on the internet talking about setting limits in ECS but after setting those in my container config, I still get the error. Any thoughts?

"ulimits": [

{

"name": "nofile",

"softLimit": 2048,

"hardLimit": 2048

}

],

0x90
asked a year ago251 views
1 Answer
0
Accepted Answer

Solved this by setting NOFILE to 10485876 in the container as well as explicitly configuring the same in /etc/apache2/envvars

0x90
answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions