By using AWS re:Post, you agree to the Terms of Use
/RDP credential were use to connect did not work, please enter new credential/

RDP credential were use to connect did not work, please enter new credential

0

Hi all,

Last 2 weeks i am facing Remote desktop connection problem. I am new in AWS.

A few day back, I had received an account suspension mail because of payment due. I made all the payment done. Now i am getting this error on login with RDP.

"RDP credential were use to connect did not work, please enter new credential "

During this I followed some steps to solve the error:

1.) My Security Group setting:-

Inbound rules are:- Http, Https, SSH, RDP, all TCP, All Traffic, Custom TCP for IPV4 and IPV6.

Outbound Rules are: All Traffic, HTTP, Custom TCP, HTTPS, SSH for IPV4 and IPV6.

2.) IAM Manager :- Create Role for AmazonEc2RoleforSSM Policy

 This My Inline Policy
 {
    "Version": "2012-10-17",
    "Statement": [
        {
            "Effect": "Allow",
            "Action": [
                "ssm:PutParameter"
            ],
            "Resource": [
                "arn:aws:ssm:us-east-2:939764493069:parameter/EC2Rescue/Passwords/i-063933c590287f4d2"
            ]
        }
    ]
}

3.) By using System Manager Run command, Changed the current password of windows as well but it's not working.

4.) Also Tried to ping the Public IPv4 address from the local machine but it's working. firewall also take off.

5.) Also tried changing internet service provider.

I don't know what am I doing wrong.

Is my account is isolated ?

Is my setting is wrong?

Could you please provide solution.

1 Answers
0

Hi,

I see that you’ve mentioned your issue above. Could you please try to redo your configurations as follow:

Security Group setting : Inbound Rules: RDP source anywhere. Outbound Rules: All traffic destination anywhere.

"If you choose Anywhere, you enable all IPv4 and IPv6 addresses to access your instance using the specified protocol. If you are adding rules for ports 22 (SSH) or 3389 (RDP), you should authorise only a specific IP address or range of addresses to access your instance."

Please see the following document for Security group rules for different use cases: https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/security-group-rules-reference.html

You can also create a new local administrator account by using the following commands:

  1. net user <NEW_USER_NAME> <PASSWORD> /add
  2. net localgroup administrators <NEW_USER_NAME> /add

Should you have any issues with running the SSM commands deattach this role ‘’AmazonSSMManagedInstanceCore’’ and continue to run the commands again. https://docs.aws.amazon.com/systems-manager/latest/userguide/setup-launch-managed-instance.html#setup-launch-managed-instance-existing

After creating the new user using SSM Run commands. Connect to your instance using the credentials of the new user. Thereafter, you can reconfigure the local administrator password from the OS.

Additionally, if your instance is domain joined please use the domain controller to change the passwords of your users.

I hope this helps.

Thank you.

answered 23 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions