By using AWS re:Post, you agree to the Terms of Use
/Keep black screen/

Keep black screen

0

Hi team,

I was wondering if there is a way to keep a black screen (lost frames) in my composition. when I create a job into MediaConvert, my video file might have a timeframe with no frames (a user turned off the camera). However, the audio kept going on.
The MediaConvert output file cut the missing frames, resulting in out-of-sync audio when there is no camera.

Are there any settings where I can choose to keep missing frames of an input video file?

Kind regards,
Pedro Elias

Edited by: pedroBlinder on Mar 9, 2021 10:21 PM

4 Answers
1

I looked at the logs and found out that your input contains variable frame rate which is only supported on MP4 and mov containers at the moment. See https://docs.aws.amazon.com/mediaconvert/latest/ug/using-variable-frame-rate-inputs.html for reference. I've highlighted this issue to the product team to include support for variable frame rate on mkv containers. Please keep an eye on the what's new page https://aws.amazon.com/about-aws/whats-new/media-services/ to find out if the support for VFR on mkv containers is included in the upcoming releases.

Regards
Naveen

answered a year ago
0

Hi @naveen-aws,

Thank you for your reply.
I'm sorry about my confusing post, I was in a rush and also my poor English doesn't help.

My EMC job has an input video file(mkv) and an external audio file(mka). The output is an mp4.

In some of our recordings, a client may start recording with the camera on but after a certain time, the client might turn off the camera, however, the recording is still running with the audio. Whereas there is no "image", the length of the video still rising also the audio still there, the client can keep talking.
Therefore my input video file might have a gap of missing frames.

When I create an EMC job, my input video file and audio file has the same length, just the input has a gap of lost frames.

The resulting output that I currently have is, media convert is cutting off the gap of missing frames. The output video starts ok, video and audio synced but when the client turns off the camera, even though, he keeps talking, media convert removes the time when the camera is off and the audio during that time goes for when the camera is on again, resulting on a desync between video and audio.

I believe just adding a black image during that timeframe might don't help me because I don't know exactly when the client turned off the camera and turned it on again.

I'm looking for something variable frame rate inputs, where media convert keeps the gap of no frames and attaches the audio on the same timeframe.

Kind regards,
Pedro Elias

answered a year ago
  • Hey Pedro, Did you resolve this, I have a similar problem to overcome. Many thanks, Phil.

0

Hi Pedro,

Are you looking to just insert a black image with silence in your transcoded output ? If yes, you can use the image inserter feature in AWS mediaconvert to achieve this. You can specify the timecode for the image to fade in and fade out depending on your input.
Instructions here : https://docs.aws.amazon.com/mediaconvert/latest/ug/graphic-overlay.html

answered a year ago
0

Hi Pedro,

I have DM'd you asking for a few details.

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions