Cannot delete volumes and network interfaces

0

Hi:

I tried to launch an EC2 instance on one of my VPCs, and after going thought the whole wizard process and hit "Launch"... it started launching my instance but it did not appear on my list of EC2 instances.

Tried a second time with same results. No EC2 instance anywhere.
Tried a third time and the instance launched just fine and appeared on the console.

The problem is that in the process two volumes where created but not attached no any instance. The same happened with two network interfaces with public IP addresses being used.

The volumes are:

  • vol-060ea8ce16c792fca
  • vol-058bcc5a282161a23

The ENIs are:

  • eni-06ef1eb05b54a055b
  • eni-0a650987096f26644

I can't delete these resources, nor the resources associated with them (VPC). Please help me deleting these.

Thank you,

Andy

asked 3 years ago27 views
5 Answers
0

Hello andyolivares,

I am sorry to hear about the issues.

Can you please try to detach the volumes (their state appears as 'in-use') manually using EC2 Console \[1] or using AWS CLI \[2]?

Also, can you please try to detach the ENIs manually using EC2 Console \[3] (using the Network Interfaces page) or using AWS CLI \[4]?

Links:
[1] https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/ebs-detaching-volume.html
[2] https://docs.aws.amazon.com/cli/latest/reference/ec2/detach-volume.html
[3] https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/using-eni.html#detach_eni
[4] https://docs.aws.amazon.com/cli/latest/reference/ec2/detach-network-interface.html

Regards,
awstomas

answered 3 years ago
0

Forgot to mention that buttons for detach appear grayed out in the AWS console.
Trying from AWS CLI reports an error of resources being "in-use".

So, cannot detach nor delete those resources. They seem to be "in-use" by a ghost EC2 instance.

answered 3 years ago
0

Also, even "force detach" does nothing :(

answered 3 years ago
0

Hello,

I have checked the 2 volumes and the 2 ENIs and they now show as in "available" state. Are you still experiencing any issues or have the issues been resolved now?

Regards,
awstomas

answered 3 years ago
0

Yes, I was able to delete them now. Thank you!

answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions