My MX record is not showing when I do a dig command

0

Hello,

I am trying to activate gmail for business for my domain hosted on Route 53. I have included all MX records as described but NX records are not showing on dig and google can not verify.

Domain name is novotthon.com.

I will appreciate your help.

Thanks,

Mehmet

asked 2 years ago195 views
4 Answers
0

Hi Mehmet,

I have performed a DNS lookup ( dig novotthon.com MX) for MX record for your domain and it does not return an answer. This means that the MX record is missing in Route 53 hosted zone.

Please create the MX record record (steps below) and perform similar lookup to confirm.

  • Sign in to the AWS Management Console and open Route 53 console at https://console.aws.amazon.com/route53/.
  • In the navigation pane, choose Hosted zones.
  • In the Records section, click Create record.
  • Leave Routing policy as Simple routing.
  • Leave Record name blank.
  • Leave Alias off (slider to the left).
  • For Record type select MX
  • In the TTL (seconds) field, leave the default value.
  • In the Value field, enter the values/mailserver provided by google.

You can also refer to google article for the same. https://support.google.com/a/answer/6149697?hl=en#zippy=%2Cstep-go-to-your-dns-records%2Csep-delete-existing-mx-records%2Cstep-add-the-new-mx-records%2Cstep-tell-google-to-find-your-new-mx-records


$ dig novotthon.com MX

; <<>> DiG 9.11.18 <<>> novotthon.com MX
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11669
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;novotthon.com. IN MX

;; AUTHORITY SECTION:
novotthon.com. 300 IN SOA ns-1162.awsdns-17.org. awsdns-hostmaster.amazon.com. 1 7200 900 1209600 86400

Regards,
Peter

Edited by: PeterN-AWS on Mar 23, 2021 10:34 PM

SUPPORT ENGINEER
Peter_N
answered 2 years ago
0

And what if this doesn't work? I did mine yesterday and the MX records still have not propagated. I thought AWS had a 60-second propagation turnaround.

How do I post my own thread on here? I don't see an option to.

Edited by: Swartz on Mar 24, 2021 11:22 AM

Swartz
answered 2 years ago
0

Hi Peter, thank you very much for your help. Actually, the reason was my stupidity, I have added the MX records to Lightsail where I host my website, problem solved. So it was not a Route 53 problem at all.

answered 2 years ago
0
SUPPORT ENGINEER
Peter_N
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions