Redshift Serverless stopped allowing connections

0

Suddenly, Redshift Serverless will not accept any connections. I have tried using psql from my machine, from an ec2 instance, everywhere the connection just times out. I have verified the security groups, checked the NAT and Route Tables. I have verified that I can ssh from one ec2 to another without problem. This has always been a publicly available box, and there have been no changes to anything on the entire VPC. I also ran the reachability analyzer, and nothing is having problems reaching parts of the network they're supposed to and the ip of redshift.

2 Answers
0

Have you tried connecting from Redshift Query Editor V2? If yes, then the problem is not "Redshift Serverless not accepting connections".
In such case, that will be network access issue.

If you are not able to connect Redshift serverelss from QEV2, then that is an issue and requires immediate support case.
If you are able to connect Redshift Serverless from QEV2, Is your EC2 is in same VPC, subnets as Redshift?

AWS
EXPERT
answered 22 days ago
0

well something funky is going on with Query Editor. I click it and I get: User information couldn't be retrieved. You must have an account to use Redshift Query Editor V2.

sqhell
answered 22 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions