Error in Creating Project in SageMaker Studio


I encountered following erorr when I tried to create a new project in SageMaker Studio. I tried to add AdminAccess to role/service-role/AmazonSageMakerServiceCatalogProductsLaunchRole, but still doesn't help. What could be the problem?

Error getting the details of Service Catalog Provisioning Parameters. Error message: ValidationException: Access denied while assuming the role arn:aws:iam::XXXXXXXXX:role/service-role/AmazonSageMakerServiceCatalogProductsLaunchRole. Args: {"productId":"prod-xxxxxxxx","provisioningArtifactId":"pa-xxxxxxxxx","pathId":"lpv2-xxxxxxxxxx"}


  • btw, I am in GCC (Government Commercial Cloud in Singapore).

  • Can you share the trust policy of that role?

asked 2 years ago1515 views
1 Answer

SageMaker assumes the AmazonSageMakerServiceCatalogProductsLaunchRole role to access and launch Projects. If you aren't using the AmazonSageMakerFullAccess policy for your Studio or user profile's execution role, make sure your Studio execution role has enough permissions to assume the AmazonSageMakerServiceCatalogProductsLaunchRole.

You don't need to add Admin access to the launch role, it has the minimum required permissions to launch a service catalog product, including assuming the AmazonSageMakerServiceCatalogProductsUseRole for running the project successfully.

answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions