mod_wsgi only available for python 2.7, needs python 3

0

Hi there,

I'm just trying to migrate some installations over to Linux 2 from the original Linux distribution. On the previous version there were mod_wsgi27, mod_wsgi36 and assorted other versions available. On the Linux 2 yum repos there is only mod_wsgi. After installing it and checking the module, I can see it is linked to python27.

It might be advisable to change either the name or at least the description so people understand what exactly this module is, but also, it would simplify life quite a bit if there was a mod_wsgi package available for the current version of python37 that installs from yum. It's really quite incomplete without it. Any chance of this being added?

Thanks

DaveRW
asked 2 years ago61 views
2 Answers
0

Thanks for the feedback and the request. I will open a request to the team that does the packaging for Amazon Linux 2 to add mod_wsgi for the python 3.7 version shipped in the Amazon Linux 2 core repository.

-Heath

answered 2 years ago
0

Great thanks, that would be super helpful and more productive than self compiling.

DaveRW
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions