1 Answer
- Newest
- Most votes
- Most comments
1
Hello.
EC2 instances launched with ElasticBeanstalk communicate with ElasticBeanstalk.
Therefore, if a public IP address is not attached to EC2, communication will not be possible and the health check will fail.
To work around this, you need to use a NAT Gateway to access ElasticBeanstalk's service endpoints, or set up a VPC endpoint.
Please check the following document, which describes the VPC endpoints required to use ElasticBeanstalk.
https://repost.aws/knowledge-center/elastic-beanstalk-vpc-endpoints
https://docs.aws.amazon.com/elasticbeanstalk/latest/dg/vpc.html
Relevant content
- AWS OFFICIALUpdated 7 months ago

Okay, thanks for the help.