By using AWS re:Post, you agree to the Terms of Use

AWS s3 sync Fails with Extant File (debug log is attached)

0

I’m attempting to use the CLI to backup a file on a Windows 10 PC to an s3 bucket. The command (in a command file) has worked for a few days but today it failed, saying the file doesn’t exist. This problem recurred after a reboot and after upgrade to the latest version of the CLI.

I’ve attached the debug log which is preceded by a chkdsk and followed by a confirmation that the file exists. Any comments would be much appreciated.

Thank you,

Don Macnaughton

1 Answer
0

For anyone else who has this problem, I see that the s3 sync command only syncs directories, not files. I was trying to sync a file. I suspect that my original version worked properly because I was using cp and not sync. I suspect that I changed cp to sync and then forgot that I had done that.

Don Macnaughton

Edited by: DonMac1503 on Apr 4, 2020 3:56 PM

answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions