By using AWS re:Post, you agree to the Terms of Use
/Error saving: Wrong parameter value '"mysql' for parameter replicate-ignore-dbDatabase names in filter value shouldn't exceed 64 symbols/

Error saving: Wrong parameter value '"mysql' for parameter replicate-ignore-dbDatabase names in filter value shouldn't exceed 64 symbols

0

Hi,

I have an RDS instance for MySQL 5.7. I'm want to set mysql, information_schema and performance_schema databases to ignore by replication in my custom parameter group. But when I try to put mysql database string in the value I receive an error:

Error saving: Wrong parameter value 'mysql' for parameter replicate-ignore-dbDatabase names in filter value shouldn't exceed 64 symbols. Supported characters includes all ASCII alphanumeric characters, _, $ and U+0080 .. U+FFFF unquoted or any characters in quotes (excluding commas). (Service: AmazonRDS; Status Code: 400; Error Code: InvalidParameterValue; Request ID: 9ffd2357-2d96-4870-8476-07c886220cd7; Proxy: null)

P.S. Parameter changing works with information_schema and performance_schema, but not when string contain mysql database

asked a month ago37 views
1 Answers
0

Dear Customer,

I understand that you want to set the parameters 'replicate-ignore-db' to 'mysql' in order to ignore the 'mysql' system database in AWS RDS instance running database MySql version 5.7. However when attempting to set the parameters an error occurs stating the following:

Error saving: Wrong parameter value 'mysql' for parameter replicate-ignore-dbDatabase names in filter value shouldn't exceed 64 symbols. Supported characters includes all ASCII alphanumeric characters, _, $ and U+0080 .. U+FFFF unquoted or any characters in quotes (excluding commas). (Service: AmazonRDS; Status Code: 400; Error Code: InvalidParameterValue; Request ID: 9ffd2357-2d96-4870-8476-07c886220cd7; Proxy: null)

The above error indicates that it is not possible to set 'replicate-ignore-db' to ignore the 'mysql' system database. This is because RDS makes use of certain 'mysql' system database tables for monitoring and architectural purposes. It is thus currently not possible to set the 'replicate-ignore-db' parameter to ignore the 'mysql' system database in AWS RDS.

I hope the above provided information is clear and helpful.

answered a month ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions