By using AWS re:Post, you agree to the Terms of Use

SageMaker Studio - Jupyter proxy function does not work

0

I am trying to run TensorBoard 2.9.0 in SageMaker Studio, as described here.

However, after launching TensorBoard, when I navigate to the proxy URL https://<DOMAIN>.studio.<REGION>.sagemaker.aws/jupyter/default/proxy/6006/, I get error 500.

I am using the "PyTorch 1.10 Python 3.8 CPU Optimized" image. Any suggestions?

I have also tried with the new JupyterLab 3 server version, but same result.

asked 4 months ago34 views
1 Answer
0

I managed to reproduce the error 500 by not starting Tensorboard. So, please, make sure you executed in Studio's terminal the command to launch Tensorboard first: tensorboard --logdir path/to/your/logs

You need to see something like:

TensorFlow installation not found - running with reduced feature set.

NOTE: Using experimental fast data loading logic. To disable, pass
    "--load_fast=false" and report issues on GitHub. More details:
    https://github.com/tensorflow/tensorboard/issues/4784

Serving TensorBoard on localhost; to expose to the network, use a proxy or pass --bind_all
TensorBoard 2.9.1 at http://localhost:6006/ (Press CTRL+C to quit)

Then, after that you can open a new tab and try to open it.

answered 3 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions