Convert t2.2xlarge to t3.2xlarge - Ubuntu Server 20.04 LTS (HVM)


Hi, i've tried to convert my instance from t2.2xlarge to t3.2xlarge but it gives me an error when i try to start it after changing instance type. What are the necessary steps to do this?

Ubuntu Server 20.04 LTS (HVM), SSD Volume Type - ami-0885b1f6bd170450c (64-bit x86)
Root device type: ebs Virtualization type: hvm ENA Enabled: Yes

asked 3 years ago405 views
4 Answers
Accepted Answer

Hi brunoaduarte,

I have done some testing and I think I know what is your issue.

Is your affected instance in us-east-1e AZ?

t3.2xlarge instances are not offered in us-east-1e AZ. This is the only AZ in us-east-1 region that does not have this instance type.

You can check the offering via AWS CLI, like this:

# aws ec2 describe-instance-type-offerings --location-type availability-zone  --filters Name=instance-type,Values=t3.2xlarge --region us-east-1 --output table  
|            DescribeInstanceTypeOfferings            |  
||               InstanceTypeOfferings               ||  
|| InstanceType |  Location    |    LocationType     ||  
||  t3.2xlarge  |  us-east-1b  |  availability-zone  ||  
||  t3.2xlarge  |  us-east-1c  |  availability-zone  ||  
||  t3.2xlarge  |  us-east-1a  |  availability-zone  ||  
||  t3.2xlarge  |  us-east-1d  |  availability-zone  ||  
||  t3.2xlarge  |  us-east-1f  |  availability-zone  ||  


If you would like to use AWS CLI, first you have to install it:  

Then configure:  

In order to solve your issue, create an AMI out of your instance and launch a new, t3.2xlarge instance in any other AZ. You can specify AZ in the "Next: Configure Instance Details" -> "Subnet" dropdown menu.

Here you will find information regarding creation of AMI:  

Hope that this will help you.


answered 3 years ago


Use the Nitro script created by AWS. It will check prerequisites on your T2 instance for changing to T3:  

As for the errors, check the Knowledge Center, you can find there most common issues:  


answered 3 years ago

Hi Daniel, thanks for the reply, but even though the script shows no error messages i still cannot start the instance after changing it's type from t2.2xlarge to t3.2xlarge

I run "" and the response is OK for all

OK NVMe Module is installed and available on your instance
OK ENA Module with version is installed and available on your instance
OK fstab file looks fine and does not contain any device names.

The following error message is presented when i try to start it

"Error starting instances The requested configuration is currently not supported. Please check the documentation for supported configurations."

I even tried to create a brand new t2.2xlarge instance and changed the type to t3 just to test it and it also doesn't work.

answered 3 years ago

Thanks Daniel! It worked.

answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions