RDP Client copy not like original after ami copy of instance

0

I made an Instance on aws to run a t2 micro .exe program with js.nodes on mongoDB pointing to the region on aws and RDP client runs the processes accordingly with api inside .env file etc. = works great

Wanted to make many of these, so: Instance duplicated by ami=worked

T2 micro RDP client = not exact copy by way of running processes are not exact like the original instance/RDP ..... why?

Had to go into SSM Agent and to get it to stay running went into powerShell and put in 2 lines of code to add-routes= worked

However 4 other processes are not EXACT like the original Instance running the original RDP client. (They do not stay in the running state after starting them. They become stopped after a few minutes. (The original RDP version does not do this)

Why is the copy sooooo much different to the point where the actual .exe program in the t2 micro is not even running in the copy version? Is there a way to make an exact copy of the RDP the same way it works with the original instance works with the original RDP?

Your thoughts? Thank you.

asked 10 months ago187 views
1 Answer
0

When working with Windows you will find that there is a SID on a machine that are set after initialization. Each machine needs to have a unique SID or it will behave as you observed.

This Knowledge Center Article explains how to use SysPrep to get a reusable AMI.

profile picture
answered 10 months ago
  • Thanks for your reply. I followed the instructions. When trying to use the password made by the .pem it no longer works with the original instance RDP. I am now locked out of my original RDP.

  • Also, the new RDP is nothing like the orginal after the SysPrep. Has empty files throughout. Were there any check boxes left unchecked? The first box was unchecked. The password was at random. Seemed straight forward, but the copy is nothing like the original which I can no longer even access to even try this again.

  • Why is my original instance, that was working just fine prior to this now say that there is an "internal server error" and is no longer working and cannot access anymore. Whole business just got shutdown.

  • If you have up a second server with the same Sid your original can also go down

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions