- Newest
- Most votes
- Most comments
I tested the above using similar scenario on my end and replicated the same error. Your investigation is correct that when we pass an incorrect identifier (without the : ) for the resource AWS::ApiGateway::UsagePlanKey while importing it, we are getting the below error which is not very clear.
There was an error creating this changeset
Index: 1, Size: 1
Using a correct identifier (for eg - 123a4bcde5:a1bfcd) resolved the issue and the resource can be imported successfully.
I would like to take advantage of this to thank you for bringing it to our notice. As we strive to improve our products, your feedback is greatly appreciated. I also understand that this might have caused inconvenience to your work-flow, and sincerely extend my apology for the same
However, I would like to add that I have passed on this feedback to the internal CFN team so that they can check if the error messaging can be improved here and add it to their roadmap.
answered 3 years ago
For anyone else ending up in this thread because they have the above, or a similar vague error message: I was trying to import an existing UsagePlanKey resource in CloudFormation and it turned out that my problem was that I did not know that the ID of a UsagePlanKey is actually a combination of Key ID and the Usage Plan ID, for instance "123abcdef:abc123"
answered 2 years ago
Relevant content
asked 2 years ago
- AWS OFFICIALUpdated 9 months ago
