By using AWS re:Post, you agree to the Terms of Use

NodeJs installation fails for new environment Rails 6

0

I am working on deploying a new Rails 6 app (2.7.4) and was making successfully making deployments until yesterday. I tried to stand up a new environment using a previously successful saved configuration and code base from just two days prior but it failed. Upon investigation I found this in my cfn-init.log:

Command 01_install_node (sudo curl --silent --location https://rpm.nodesource.com/setup_14.x | sudo bash -
sudo yum -y install nodejs
) failed

Someone else posted a similar issue at the beginning of October and a possible solution was to update a cert on the AWS Linux II instance, but when I ran this command:
sudo yum install https://cdn.amazonlinux.com/patch/ca-certificates-update-2021-09-30/ca-certificates-2021.2.50-72.amzn2.0.1.noarch.rpm

...I got the following error: "...does not update installed package.
Error: Nothing to do"

Edited by: tfossum on Nov 4, 2021 7:50 PM

asked a year ago14 views
1 Answer
0

This seemed to have to do with aws experiencing interrupted access to the nodejs distribution mirrors. https://github.com/nodesource/distributions/issues/1290

Edited by: tfossum on Nov 5, 2021 12:15 PM

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions