Ruby 2.6.5 runtime missing on Amazon Linux Standard 3.0 image

0

I have a ruby project and I am trying to build via AWS codedeploy and having some issues specifying the ruby version. I am using Ruby 2.6.5 and I am using AWS Codedeploy standard image (aws/codebuild/standard:2.0) because according to the docs it supports Ruby 2.6.5. .ruby-version has 2.6.5. I also attempted a build where I put "runtime-versions: ruby: 2.6.5" in the buildspec but that threw the following error: "Phase context status code: YAML_FILE_ERROR Message: Unknown runtime version named '2.6.5' of ruby. This build image has the following versions: 2.6". This is my buildspec.

version: 0.2
phases:
  install:
    runtime-versions:
      ruby: 2.6.5
    commands:
      - echo Installing Bundler...
      - gem install bundler -v 2.2.27
      - bundle install
  build:
    commands:
       - bundle exec rspec

I also tried using aws/codebuild/amazonlinux2-x86_64-standard:3.0-20.03.13 image version from AL Standard 3.0 image instead of the latest but I get the same error while on github I see ruby version 2.6.5 has been added https://github.com/aws/aws-codebuild-docker-images/tree/20.03.13. I also tried Ubuntu Standard 5.0 and same thing. What am I missing?

jedrek
asked a year ago23 views
No Answers

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions