By using AWS re:Post, you agree to the Terms of Use

SageMaker Studio will not load

0

Morning of 12/17 I loaded SageMaker Studio, and created an Autopilot experiment. It ran for 2 hours and was successful.

Afterwards, I exited SageMaker Studio. Ever since that point, I have been unable to re-enter Studio. It is now 24 hours later.

I either receive a response from Chrome:

This page isn’t working
d-*************.studio.us-east-2.sagemaker.aws didn’t send any data.
ERR_EMPTY_RESPONSE

Or, I get an error message:
The JupyterServer app default encoutered a problem and was stopped.
Details: InternalFailure

I get the option to "Restart Now," but it never works.

asked 3 years ago649 views
8 Answers
0

Hello. I ran into a similar problem. I think SageMaker Studio, since it's in preview, is not yet a super-stable platform. To resolve this issue I just kept trying to launch the sagemaker studio from the aws console ('open amazon sagemaker studio' button from within the amazon SageMaker > Amazon SageMaker Stuiod > d-***** men). I received the same error about ten times but eventually I was able to get through to see the notebook I had previously created.

Hope this helps!

answered 3 years ago
0

I see the same issue. SM Studio was working on the evening of 1/6/2020. I shut down the Juypter Lab and haven't been able to access it since. I've tried accessing via the SSO dashboard, as well as an admin user via the AWS console.

CHROME returns:

This page isn’t working d-*********.studio.us-east-2.sagemaker.aws didn’t send any data.
ERR_EMPTY_RESPONSE

FIREFOX returns:

Secure Connection Failed
An error occurred during a connection to d-*********.studio.us-east-2.sagemaker.aws.
The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

SAFARI returns:

Safari Can't Open the Page
Safari can't open the page "https://d-*******.studio.us-east-2.sagemaker.aws/jupyter/default" because the server unexpectedly dropped the connection. This sometimes occurs when the server is busy. Wait for a few minutes, and then try again.

I tried for a few hours last night and again this morning. The problem persists. Any suggestions or support with this would be greatly appreciated. Thanks.

answered 3 years ago
0

Still having the same issue, trying about once a day since the original errors.

answered 3 years ago
0

I have the same issue. I have shut it down last night and could not find a way to open it or restart the whole amazon sagemaker studio service.

answered 3 years ago
0

I was able to fix this by completely deleting my Studio instance with the AWS CKI. Of course you'll use any ephemaral data. You can then start over from scratch. Here is the sequence of commands.

aws sagemaker delete-app --domain-id yourDomainID --user-profile-name yourProfileName --app-type KernelGateway --app-name base-python
aws sagemaker delete-app --domain-id yourDomainID --user-profile-name yourProfileName --app-type JupyterServer --app-name default
aws sagemaker delete-user-profile --domain-id yourDomainID --user-profile-name yourProfileName
aws sagemaker delete-domain --domain-id yourDomainID

answered 3 years ago
0

I am facing a similar problem for one of my SageMaker users. The default app, which is the Jupyter server, keeps failing while trying to launch SageMaker studio. I am receiving the following message: "The JupyterServer app default encountered a problem and was stopped.". I click on the Restart button, but the message appears again. Does anyone know how can I solve this issue? Or do you recommend paying for AWS support?

answered 2 years ago
0

Had the same issue and managed to fix it (and preserve my data).

  1. In AWS console navigate to SageMaker Studio
  2. In the users section at the top, open the user (user details page) that is experiencing this issue.
  3. At the bottom of the page, delete all apps for this user. There will be the default app (which is jupyter server) and sometimes others like KernelGateway. DO NOT DELETE THE ACTUAL USER PROFILE.
  4. When all apps for this user is deleted, go back to SageMaker Studio and click on the "Open Studio" link for that user.
  5. It will take some time, but SageMaker Studio will reinitialize that Jupyter Notebook.

The notebook will open and you should have all your data as it was before.

Edited by: Noobie on Oct 4, 2020 4:41 PM

Edited by: Noobie on Oct 4, 2020 4:43 PM

answered 2 years ago
0

This method works, thanks for sharing.

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions