RDS Proxy currently doesn’t support the option plan_cache_mode

0

Hello!

I'm trying to connect a Permify pod to an RDS PostgreSQL instance through a RDS Proxy. Unfortunately, the application crash after a while with the error message

msg="failed to initialize database"
error="pinging pools failed: write pool ping failed: failed to connect to ... server error: FATAL: Feature not supported: RDS Proxy currently doesn’t support the option plan_cache_mode. (SQLSTATE 0A000)"

I also opened an issue on the Permify Github.

I'm currently using Aurora PostgreSQL (Compatible with PostgreSQL 15.4) - default for major version 15 with version v0.9.8 of Permify. I tried to bypass the RDS Proxy and it works. Is there a solution to connect to the database through the RDS Proxy ?

Thank you

2 Answers
0

Hi,

Permify allows to customize the Postgres setup: see https://docs.permify.co/setting-up/configuration

# The database section specifies the database engine and connection settings,
# including the URI for the database, whether or not to auto-migrate the database,
# and connection pool settings.
database:
  engine: postgres
  uri: postgres://user:password@host:5432/db_name
  auto_migrate: false
  max_open_connections: 20
  max_idle_connections: 1
  max_connection_lifetime: 300s
  max_connection_idle_time: 60s
  garbage_collection:
    enabled: true
    interval: 200h
    window: 200h
    timeout: 5m

So, can you try to disable plan_cache_mode in this config to see if you get your app to work?

Best,

Didier

profile pictureAWS
EXPERT
answered 4 days ago
profile picture
EXPERT
reviewed 4 days ago
0

Hi,

I tried, but disable plan_cache_mode in the configuration seems not implemented. The documentation doesn't mention it.

Thx

fagi
answered 4 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions