IoT core connection with MQTT explorer

0

Hi I was trying to access the IoT core broker with MQTT Explorer. I can't connect to it somehow ? i've been using: mqtt://****-ats.iot.eu-west-3.amazonaws.com:8883 and insert the client cerftificates in to the mqtt explorer but somehow that doesn't seem to work ? Does someone has any expierence with this ? Because i have no clue what i'm doing wrong at the moment.

asked a year ago1236 views
2 Answers
1

MQTT Explorer subscribes by default to $SYS/# topic. This topic is not supported by AWS IoT Core and will cause the broker to disconnect the client.

To fix, open the Advanced settings and remove the $SYS/# topic from the subscription list by clicking onto it. Ensure also the the clientId you are using to connect is allowed by the AWS IoT Policy attached to the certificate

This is the setup in the main window:

Enter image description here

AWS
EXPERT
answered a year ago
0

Hi! can you provide a little bit more detail of you setup ? With the information you give I can think of two options :

  • Have you chained the Amazon Root CA with your clients certificate ? You can have a look
https://docs.aws.amazon.com/iot/latest/developerguide/server-authentication.html#server-authentication-certs
  • Is the certificate active ? Is it associated with the correct policy with the needed permissions ?
AWS
answered a year ago
  • At the moment our remote installation is sending data through mqtt to IoT Core. I can see that the data is correctly comming in by using the test explorer. Now i want to access the incomming data on the IoT Core with the MQTT explore application to see if everything is working fine and for further development. I'm using the certificates from the excisting connection

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions