Add "node name" to managed nodes in fleet manager

0

Hello, I'm looking to add node names to my managed nodes but I can't find how/where to do so

asked 24 days ago41 views
2 Answers
0

Hi,

You can add/rename node names directly Fleet Manager by editing the instance tags. Follow below steps to do so:

  1. Open SSM, Fleet Manager
  2. Click on the "Node ID" that you want to edit,
  3. At the bottom of your screen you should see a column for "Tags"
  4. Click "Edit" and set KEY=Name, VALUE=The_Name_OF_Your_Node
  5. Save.

Once the "Name" tag has been added/updated this should in turn update "node name". Alternatively you can set a "Name" tag on your EC2 instance from the EC2 Dashboard which should update the node name as well.

Let me know if this helps!

[1] Tagging AWS resources - https://docs.aws.amazon.com/general/latest/gr/aws_tagging.html

profile picture
SUPPORT ENGINEER
Lundi
answered 24 days ago
  • Hey thank you for the response, I'm working with raspberry pi instances linked with SSM agents, not sure if this will make a difference. I added a tag with key=name and value=the name i want, and nothing has showed up under node name, let me know if there is anything else I can do, Thank you

  • Hi,

    Apologies for reaching back to you so late on this as I was offline, okay so as I understand these are Hybrid Instances and not EC2, I haven't tested whether tagging works with hybrid instances. I will schedule sometime to test this on my end today and will advise once done.

0

Hello,

Adding this as a seperate answer not to get lost in comments, I tried to replicate the behavour you are experiencing using Hybrid activation on my local virtualbox VM. The changes worked as expected. See below:

  1. I created a hybrid activation for my virtualbox Ubuntu VM
  2. Once registered I was able to see my instance on fleet manager and I tagged the instance from Fleet Manager as mentioned in step3.

Enter image description here

  1. See "Tags Section" with my naming tag "TestingHybrid"

Enter image description here

As you can see my tag propagated to the "Node Name" field, Some notes below:

A. I tested with Ubuntu VM from virtualbox but registration works the same for Raspberry Pi as you can see in docs so this should not be an issue since we tagging the resource on AWS and not the platform or OS.

B. If the issue is affecting more than 1 managed instance, it might be beneficial for you to open up a case with AWS Premium Support to further investigate "Why the tags are not propagating"

C. To test this further are you able to test with a different platform (e.g virtualbox) to check if it's yielding the same result?

Feel free to update this correspondence if I missed anything

profile picture
SUPPORT ENGINEER
Lundi
answered 17 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions