RDS Blue/Green deployment on a very large Database seems too long


Hello, We are trying to use the new RDS Blue/Green Deployments feature to upgrade Aurora Mysql 5.6 to 5.7. We did some tests on a small DB (a few GiB) and everything worked fine. So we tried running a Blue/Green on a 3.6 TiB Database (with billions of rows), but it seems RDS can't create the Green instance, it's been on status Provisioning for 6 days now and we can't find any progress information, we guess things are "blocked".

Should we wait longer ? Is there any limitation on the DB size to use Blue/Green deployment ?

1 Answer

It appears that you may have either deleted or revoked permissions to the KMS key for this cluster which is blocking the provisioning of the Blue Green Deployment. You might open a support case with AWS support to work through this error. thanks,

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions