By using AWS re:Post, you agree to the Terms of Use

Questions tagged with Amazon Athena

Sort by most recent

Browse through the questions and answers listed below or filter and sort to narrow down your results.

Athena HIVE_METASTORE_ERROR

I am new to AWS and exploring Athena for querying S3 objects. I am using AWS Glue Crawler for data catalog. I have successfully created table using Crawler for my JSON files available on the S3 location. The JSON file is having a complex structure with nested JSON objects. The created schema for the table is - ![Schema for the table](https://repost.aws/media/postImages/original/IMRR0ImqUWQfi5CeUAvqA84g) While I am querying the table with query - ``` SELECT * FROM "mydatabase"."brulocale" limit 10; ``` I am getting the error as below - ``` HIVE_METASTORE_ERROR: Error: : expected at the position 1161 of 'struct<loading:string,launch:struct<pageTitle:string,model:string,serial:string,problemCategory:string,problemType:string,launchButton:string,applianceType:string,manufacturer:string,serviceRecord:string,issueNotes:string>,home:struct<pageTitle:string,loginButton:string,helpText:string>,nope:struct<pageTitle:string,loginButton:string,helpText:string>,widgets:struct<issueHistory:string,faqs:string,topIssues:string,manuals:string,videos:string,noFAQs:string,noTopIssues:string,noVideos:string,noManuals:string,parts:string,partsRecommed:string,warrantyInfo:struct<registrationDate:string,installationDate:string,fullWarrantyDate:string,ssWarantyDate:string,partsOnlyDate:string,serialNumber:string,modelNumber:string,warrantyType:string,warrantyDescription:string>,FAQ:string,vidéos:string>,mediaWidget:struct<issueHistory:string,faqs:string,topIssues:string,manuals:string,videos:string,noFAQs:string,noTopIssues:string,noVideos:string,noManuals:string,partsRecommed:string>,chatbot:struct<title:string,solution:struct<moreInfo:string,lessInfo:string,moreSolution:string,lessSolution:string>,attachment:struct<moreSolution:string,lessSolution:string>,options/select_one:struct<lessOption:string,moreOption:string>>,applianceInfo:string,topLoadWashers:string,type:string,model#:string,serial#:string,top5Issues:string,noRecords:string,date:string,problem:string,jobDesc:string,parts:string,submit:string,feedbackDrawer.title:string,stc:string,swp:string,ns:string,stcResponse:string,swpResponse:string,nsResponse:string,stcResponseFailed:string,swpResponseFailed:string,nsResponseFailed:string,landingPage.welcomeMessage:string,project:string,partsPredicton.noData:string,applianceInfo.notFound:string>' but '/' is found. (Service: null; Status Code: 0; Error Code: null; Request ID: null; Proxy: null) This query ran against the "mydatabase" database, unless qualified by the query. Please post the error message on our forum or contact customer support with Query Id: 3ff36139-b116-41c1-be4a-f2f2872df446 ``` Can anyone please help me out to understand what could be the issue? Thanks.
0
answers
0
votes
55
views
asked 2 months ago
0
answers
0
votes
25
views
asked 2 months ago