By using AWS re:Post, you agree to the Terms of Use

Questions tagged with AWS Device Farm

Sort by most recent

Browse through the questions and answers listed below or filter and sort to narrow down your results.

Device Farm Video is not showing application interaction

Hi, I am running my test on device farm. From the test specification log, it shows that my test has passed. However from the video recording, it is always stuck on the default mobile homescreen. How do i get the video recording to capture the test interaction instead of just the homescreen. thanks! ``` [TestNG] INVOKING CONFIGURATION: "Command line test eca2ebbd-c83a-4609-84f0-bb52a16b1afc" - @BeforeTest Tests.LoginTest.setUpPage() [TestNG] PASSED CONFIGURATION: "Command line test eca2ebbd-c83a-4609-84f0-bb52a16b1afc" - @BeforeTest Tests.LoginTest.setUpPage() finished in 118 ms [Invoker 1508395126] Keeping method TestBase.navigateTo()[pri:0, instance:Tests.LoginTest@15975490] for class [TestClass name=class Tests.LoginTest] [Invoker 1508395126] Invoking @BeforeClass TestBase.navigateTo()[pri:0, instance:Tests.LoginTest@15975490] [TestNG] INVOKING CONFIGURATION: "Command line test eca2ebbd-c83a-4609-84f0-bb52a16b1afc" - @BeforeClass Tests.AbstractBaseTests.TestBase.navigateTo() [TestNG] PASSED CONFIGURATION: "Command line test eca2ebbd-c83a-4609-84f0-bb52a16b1afc" - @BeforeClass Tests.AbstractBaseTests.TestBase.navigateTo() finished in 2846 ms [Invoker 1508395126] Keeping method LoginTest.logOut()[pri:0, instance:Tests.LoginTest@15975490] for class [TestClass name=class Tests.LoginTest] [TestNG] INVOKING: "Command line test eca2ebbd-c83a-4609-84f0-bb52a16b1afc" - Tests.LoginTest.loginFail() [Invoker 1508395126] Invoking Tests.LoginTest.loginFail [TestNG] PASSED: "Command line test eca2ebbd-c83a-4609-84f0-bb52a16b1afc" - Tests.LoginTest.loginFail() finished in 7446 ms [Invoker 1508395126] Keeping method LoginTest.logOut()[pri:0, instance:Tests.LoginTest@15975490] for class [TestClass name=class Tests.LoginTest] [Invoker 1508395126] Invoking @AfterMethod LoginTest.logOut()[pri:0, instance:Tests.LoginTest@15975490] [TestNG] INVOKING CONFIGURATION: "Command line test eca2ebbd-c83a-4609-84f0-bb52a16b1afc" - @AfterMethod Tests.LoginTest.logOut() [TestNG] PASSED CONFIGURATION: "Command line test eca2ebbd-c83a-4609-84f0-bb52a16b1afc" - @AfterMethod Tests.LoginTest.logOut() finished in 827 ms [Invoker 1508395126] Keeping method LoginTest.logOut()[pri:0, instance:Tests.LoginTest@15975490] for class [TestClass name=class Tests.LoginTest] ```
0
answers
0
votes
14
views
asked 5 months ago

Webdriver testcases are failing while setting connection

Trying to deploy a basic webdriver.io + nodejs test on devicefarm but always for ios device test cases are getting stuck at Testcase is failing: job arn: arn:aws:devicefarm:us-west-2:612756076442:job:02bd6c95-640d-43b3-82eb-6f618777ac73/1a6364f3-7528-44b1-afa1-d6c2dc51d881/00000 ``` 2022-05-04T22:40:58.353Z ERROR @wdio/runner: Error: Failed to create session. [0-0] Unable to connect to "http://localhost:4723/", make sure browser driver is running on that address. [0-0] If you use services like chromedriver see initialiseServices logs above or in wdio.log file as the service might had problems to start the driver. [0-0] at startWebDriverSession (/private/tmp/scratchY4h2F6.scratch/test-packagex5aknf/node_modules/integration/node_modules/webdriver/build/utils.js:72:15) [0-0] at process.processTicksAndRejections (node:internal/process/task_queues:95:5) [0-0] at async Function.newSession (/private/tmp/scratchY4h2F6.scratch/test-packagex5aknf/node_modules/integration/node_modules/webdriver/build/index.js:46:45) [0-0] at async remote (/private/tmp/scratchY4h2F6.scratch/test-packagex5aknf/node_modules/integration/node_modules/webdriverio/build/index.js:77:22) [0-0] at async Runner._startSession (/private/tmp/scratchY4h2F6.scratch/test-packagex5aknf/node_modules/integration/node_modules/@wdio/runner/build/index.js:223:56) ``` and for android testcases is asking for node version greater than 12 (after adding nvm install 18.1.0 in yaml)
0
answers
0
votes
22
views
asked 5 months ago

Device Farm test setup fails due to 'ascii' codec can't decode byte

I am trying to run Appium Python tests for Android devices. However, my test setup fails with the following error: 'ascii' codec can't decode byte 0xcc in position 58: ordinal not in range(128). My tests run locally just fine, and from the limited information in the logs here I'm unable to decipher where the problem lies. What steps can I take to troubleshoot this issue? Entirety of test setup log is below: ``` [{"attachment_id": null, "parent_id": null, "timestamp": "2022-04-12T23:02:46.018578Z", "level": "Info", "pid": 3106, "data": "Starting Setup Suite", "source": "Harness", "tag": null, "subtype": "Text", "tid": 3111, "type": "Message", "id": 13}, {"attachment_id": null, "parent_id": null, "timestamp": "2022-04-12T23:02:46.019150Z", "level": "Info", "pid": 3106, "data": "Starting Setup Test", "source": "Harness", "tag": null, "subtype": "Text", "tid": 3111, "type": "Message", "id": 15}, {"attachment_id": null, "parent_id": null, "timestamp": "2022-04-12T23:02:48.555726Z", "level": "Debug", "pid": 31496, "data": "Binder ioctl to enable oneway spam detection failed: Invalid argument", "source": "Device", "tag": "ProcessState", "subtype": "Text", "tid": 31496, "type": "Message", "id": 16}, {"attachment_id": null, "parent_id": null, "timestamp": "2022-04-12T23:02:52.875809Z", "level": "Errored", "pid": 3106, "data": "'ascii' codec can't decode byte 0xcc in position 58: ordinal not in range(128)", "source": "Harness", "tag": null, "subtype": "Text", "tid": 3127, "type": "Message", "id": 17}, {"attachment_id": null, "parent_id": null, "timestamp": "2022-04-12T23:02:53.334113Z", "level": "Errored", "pid": 3106, "data": "'ascii' codec can't decode byte 0xcc in position 58: ordinal not in range(128)", "source": "Harness", "tag": null, "subtype": "Text", "tid": 3111, "type": "Message", "id": 22}, {"attachment_id": null, "parent_id": null, "timestamp": "2022-04-12T23:02:53.334757Z", "level": "Info", "pid": 3106, "data": "Finished Setup Test", "source": "Harness", "tag": null, "subtype": "Text", "tid": 3111, "type": "Message", "id": 24}, {"attachment_id": null, "parent_id": null, "timestamp": "2022-04-12T23:02:53.336363Z", "level": "Info", "pid": 3106, "data": "Finished Setup Suite", "source": "Harness", "tag": null, "subtype": "Text", "tid": 3111, "type": "Message", "id": 27}] ```
2
answers
0
votes
17
views
asked 6 months ago