Questions tagged with Linux Provisioning

Content language: English

Sort by most recent

Browse through the questions and answers listed below or filter and sort to narrow down your results.

Hi Team, i have successfully built a Wordpress site on a personal Lightsail account, and post development i was able to package it and the DB, and setup it up on a new instance on the clients AWS account and transferred all the files and the db, the site works completely fine. Except i am unable to update the Wordpress core. I have tried updating the file permissions and nothing has worked, the error i get is "The update cannot be installed because some files could not be copied. This is usually due to inconsistent file permissions.: wp-admin/includes/update-core.php" What i doubt is the problem is with the user role that triggers the update or the write access to these folders, so i tried to do the update through the wp-cli and i got the same error, even though i ran it sudo. all the files have the permission of 664/644 and dir 775/755. and the file ownership is bitnami:daemon. The plugin/theme updates are working fine, the media uploads without an issues, only the core update im having an issue. I will put out a short decription on how to move from lightsail to another account based lightsail, once i can rectify this. Regards, Shiva
0
answers
0
votes
14
views
asked a month ago
hello, i installed Docker-Compose mailserver on EC2, now i cant connect to that EBS, once i Attach another EBS it works, as i checked AWS will block EC2 with their firewall! how can i connect to my old EC2+EBS again? thanks
1
answers
0
votes
42
views
asked a month ago
I had to upgrade PHP 8.1 and I have everything working except Redis. When I try to install php-pecl-redis, I get the following errors. Resolving Dependencies --> Running transaction check ---> Package php-pecl-redis.x86_64 0:2.2.8-1.el7 will be installed --> Processing Dependency: php(api) = 20100412-64 for package: php-pecl-redis-2.2.8-1.el7.x86_64 --> Processing Dependency: php(zend-abi) = 20100525-64 for package: php-pecl-redis-2.2.8-1.el7.x86_64 --> Processing Dependency: php-pecl-igbinary(x86-64) for package: php-pecl-redis-2.2.8-1.el7.x86_64 --> Running transaction check ---> Package php-pecl-igbinary.x86_64 0:1.2.1-1.el7 will be installed --> Processing Dependency: php(api) = 20100412-64 for package: php-pecl-igbinary-1.2.1-1.el7.x86_64 --> Processing Dependency: php(zend-abi) = 20100525-64 for package: php-pecl-igbinary-1.2.1-1.el7.x86_64 ---> Package php-pecl-redis.x86_64 0:2.2.8-1.el7 will be installed --> Processing Dependency: php(api) = 20100412-64 for package: php-pecl-redis-2.2.8-1.el7.x86_64 --> Processing Dependency: php(zend-abi) = 20100525-64 for package: php-pecl-redis-2.2.8-1.el7.x86_64 --> Finished Dependency Resolution Error: Package: php-pecl-redis-2.2.8-1.el7.x86_64 (epel) Requires: php(api) = 20100412-64 Installed: php-common-8.1.12-1.amzn2.x86_64 (@amzn2extra-php8.1) php(api) = 20210902-64 Available: php-common-5.4.16-43.amzn2.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-43.amzn2.0.1.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-43.amzn2.0.2.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-43.amzn2.0.3.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-43.amzn2.0.4.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-45.amzn2.0.5.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-45.amzn2.0.6.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-46.amzn2.0.2.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-8.1.11-1.amzn2.x86_64 (amzn2extra-php8.1) php(api) = 20210902-64 Error: Package: php-pecl-igbinary-1.2.1-1.el7.x86_64 (epel) Requires: php(api) = 20100412-64 Installed: php-common-8.1.12-1.amzn2.x86_64 (@amzn2extra-php8.1) php(api) = 20210902-64 Available: php-common-5.4.16-43.amzn2.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-43.amzn2.0.1.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-43.amzn2.0.2.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-43.amzn2.0.3.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-43.amzn2.0.4.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-45.amzn2.0.5.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-45.amzn2.0.6.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-5.4.16-46.amzn2.0.2.x86_64 (amzn2-core) php(api) = 20100412-64 Available: php-common-8.1.11-1.amzn2.x86_64 (amzn2extra-php8.1) php(api) = 20210902-64 Error: Package: php-pecl-redis-2.2.8-1.el7.x86_64 (epel) Requires: php(zend-abi) = 20100525-64 Installed: php-common-8.1.12-1.amzn2.x86_64 (@amzn2extra-php8.1) php(zend-abi) = 20210902-64 Available: php-common-5.4.16-43.amzn2.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-43.amzn2.0.1.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-43.amzn2.0.2.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-43.amzn2.0.3.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-43.amzn2.0.4.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-45.amzn2.0.5.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-45.amzn2.0.6.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-46.amzn2.0.2.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-8.1.11-1.amzn2.x86_64 (amzn2extra-php8.1) php(zend-abi) = 20210902-64 Error: Package: php-pecl-igbinary-1.2.1-1.el7.x86_64 (epel) Requires: php(zend-abi) = 20100525-64 Installed: php-common-8.1.12-1.amzn2.x86_64 (@amzn2extra-php8.1) php(zend-abi) = 20210902-64 Available: php-common-5.4.16-43.amzn2.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-43.amzn2.0.1.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-43.amzn2.0.2.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-43.amzn2.0.3.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-43.amzn2.0.4.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-45.amzn2.0.5.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-45.amzn2.0.6.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-46.amzn2.0.2.x86_64 (amzn2-core) php(zend-abi) = 20100525-64 Available: php-common-8.1.11-1.amzn2.x86_64 (amzn2extra-php8.1) php(zend-abi) = 20210902-64 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest
0
answers
0
votes
17
views
James_M
asked a month ago
my t3.micro have been runing fine. Now I stopped and restarted today, it only passed one of 2 status check. Tried "reboot", and retried "stop and start", same issue. The system log indicates no error, and the last line is: "Ubuntu 22.04.1 LTS ip-172-30-1-84 ttyS0".
1
answers
0
votes
15
views
asked 2 months ago
Hi there, I am attempting to finish setting up an EC2 to enable a research tool to be deployed online. I have had troubles with the "Certificate automation: Let's Encrypt with Certbot on Amazon Linux 2" instructions, linked below: [https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/SSL-on-amazon-linux-2.html#letsencrypt:~:text=Linux%202%20AMI.-,Certificate%20automation%3A%20Let%27s%20Encrypt%20with%20Certbot%20on%20Amazon%20Linux%202,-Warning]() I have installed Apache through the following commands: ``` sudo yum install -y httpd cd /tmp sudo wget -O epel.rpm –nv \ https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm sudo yum install -y ./epel.rpm sudo yum install python2-certbot-apache.noarch ``` I enter the following commands into a .pem bash terminal in vscode: ``` sudo wget -r --no-parent -A 'epel-release-*.rpm' https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/e/ sudo rpm -Uvh dl.fedoraproject.org/pub/epel/7/x86_64/Packages/e/epel-release-*.rpm sudo yum-config-manager --enable epel* sudo yum update -y sudo yum repolist all ``` When confirming that the EPEL is enabled, my information in vscode differs from what the instructions state. Please view the images below: ##### **Instructions:** ![Enter image description here](/media/postImages/original/IMUeVDGLN7T26Q5apMK_z7EA) ##### **My information:** ![Enter image description here](/media/postImages/original/IMvm5lxnh1Tv-0ewY4QFU0Fw) Any guidance on where a mistake may have been made, or why i am not able to enable these services would be greatly appreciated! Many Thanks,
1
answers
0
votes
24
views
asked 2 months ago
I'm using Microsoft RDP on Mac (intel chip, Ventura 13.1) to connect to a Linux instance. Other team members can connect to EC2 instances with RDP (on Windows computer), but when I connect I suffer from extreme latency - it's so extreme that I cannot actually work (takes 5-10 seconds to respond to keyboard clicks, and sometimes more). I can connect via SSH smoothly, but RDP is a problem even after launching different instances type in different regions (which are closer to me), but nothing solved the issue. I'm really lost, any ideas?
2
answers
0
votes
14
views
asked 2 months ago
Hi, I have created a new volume from a snapshot and increased it’s size to 100 GB, then attached the volume to my instance. But I can not grow the partitions and lsblk doesn’t show a bigger volume. Here is the output of lsblk: ❯ lsblk NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINTS loop0 7:0 0 25.1M 1 loop /snap/amazon-ssm-agent/5656 loop1 7:1 0 24.4M 1 loop /snap/amazon-ssm-agent/6312 loop2 7:2 0 49.6M 1 loop /snap/snapd/17883 loop3 7:3 0 55.6M 1 loop /snap/core18/2667 loop4 7:4 0 63.2M 1 loop /snap/core20/1738 loop6 7:6 0 103M 1 loop /snap/lxd/23541 loop7 7:7 0 63.3M 1 loop /snap/core20/1778 loop9 7:9 0 49.8M 1 loop /snap/snapd/17950 loop10 7:10 0 55.6M 1 loop /snap/core18/2654 loop11 7:11 0 111.9M 1 loop /snap/lxd/24322 xvda 202:0 0 16G 0 disk ├─xvda1 202:1 0 15.9G 0 part / ├─xvda14 202:14 0 4M 0 part └─xvda15 202:15 0 106M 0 part /boot/efi Here is the output of > sudo resize2fs /dev/xvda1 resize2fs 1.46.5 (30-Dec-2021) The filesystem is already 4165883 (4k) blocks long. Nothing to do! Does anyone knows what could be the cause of the issue? Thank you very much.
2
answers
0
votes
33
views
asked 2 months ago
Hey there, I have a Red Hat compatible OS with Arm architect ISO file, I want to port this ISO to AWS as an AMI for EC2 instances, so I have created a VM on c6g.metal instance, which supports KVM virtualization, and I plan to install the ISO as a temp VM, and import it as a AMI or a EBS Snapshot -> AMI by using VM Import. The command I launch the VM is ``` virt-install \ --name rhel-compatible-linux-arm64 \ --memory 4096 \ --vcpus 4 \ --disk size=10 \ --os-variant rhel7.5 \ --location /home/ec2-user/rhel-compatible-linux-arm64.iso \ --initrd-inject /home/ec2-user/anaconda-ks.cfg \ --extra-args="inst.ks=file:/anaconda-ks.cfg console=tty0 console=ttyS0,115200n8" ``` The question is , is there any steps or docs on how to do it? Here are my challenges: * The ISO file will start a Graphic installation UI, how do I connect to the VM that is on EC2 graviton instance (c6g.metal) to complete the installation process from my laptop? Does it use VNC protocol (I assume the connection is "qemu+ssh://")? Which ports should I open from Security Group (5901)? * I change the installation from "graphical" to "text", and try to install it with a kickstart file, but it always fail at somewhere during the boot process, see picture for more details. ``` [ 191.550201][ 3] audit: type=1130 audit(1674990734.180:9): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-udev-settle comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success' [ 191.764756][ 2] audit: type=1130 audit(1674990734.400:10): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=multipathd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success' [ 192.322576][ 2] audit: type=1130 audit(1674990734.950:11): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-setup comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success' Generating "/run/initramfs/rdsosreport.txt" Entering emergency mode. Exit the shell to continue. Type "journalctl" to view system logs. You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot after mounting them and attach it to a bug report. Press Enter for maintenance (or press Control-D to continue): ``` ![Enter image description here](/media/postImages/original/IMnuNOfP8xTNynE61glai55w) * By looking into the logs in initramfs, errors, see picture for more details. ``` [ 0.988546] localhost kernel: pci 0000:00:01.3: PCI bridge to [bus 04] ...skipping... [ 678.604694] localhost systemd-vconsole-setup[4213]: KD_FONT_OP_GET failed while trying to get the font metadata: Function not implemented [ 678.614684] localhost systemd-vconsole-setup[4213]: Fonts will not be copied to remaining consoles [ 678.638810] localhost systemd[1]: systemd-vconsole-setup.service: Succeeded. [ 678.660426] localhost systemd[1]: Started Setup Virtual Console. [ 678.671240] localhost audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-vconsole-setup comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success' [ 678.675142] localhost audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-vconsole-setup comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success' [ 678.695610] localhost kernel: audit: type=1130 audit(1674991221.320:12): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-vconsole-setup comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success' [ 678.696216] localhost kernel: audit: type=1131 audit(1674991221.330:13): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-vconsole-setup comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success' [ 678.713619] localhost systemd[1]: Starting Dracut Emergency Shell... [ 679.331801] localhost systemd[1]: Received SIGRTMIN+21 from PID 823 (plymouthd). [ 679.345576] localhost systemd[1]: Received SIGRTMIN+21 from PID 823 (plymouthd). ``` ![Enter image description here](/media/postImages/original/IMPpWXrXZoTveXDlnexdhZZQ) The kickstart config I'm using ``` #version=DEVEL # Use graphical install graphical %post --nochroot #####copy kyinfo and LICENSE if [ -e /tmp/.kyinfo ];then echo y | cp -a /tmp/.kyinfo $ANA_INSTALL_PATH/etc/ fi if [ -e /tmp/LICENSE ];then echo y | cp -a /tmp/LICENSE $ANA_INSTALL_PATH/etc/ fi if [ -e /run/install/repo/.kyinfo ];then echo y | cp -a /run/install/repo/.kyinfo $ANA_INSTALL_PATH/etc/ fi if [ -e /run/install/repo/LICENSE ];then echo y | cp -a /run/install/repo/LICENSE $ANA_INSTALL_PATH/etc/ fi ##### kylin postaction ## cdrom install, copy .kylin-post-actions if [ -e /run/install/repo/.kylin-post-actions ];then echo y | cp -a /run/install/repo/.kylin-post-actions /tmp/.kylin-post-actions echo "repo=/run/install/repo" > /tmp/.kylin-repo fi ## copy kylin post scripts in new os if [ -e /tmp/.kylin-post-actions ];then echo y | cp -a /tmp/.kylin-post-actions $ANA_INSTALL_PATH/bin fi if [ -e /tmp/.kylin-repo ];then echo y | cp -a /tmp/.kylin-repo $ANA_INSTALL_PATH/tmp/ fi ## copy and run .kylin-post-actions-nochroot if [ -e /run/install/repo/.kylin-post-actions-nochroot ];then echo y | cp -a /run/install/repo/.kylin-post-actions-nochroot /tmp/.kylin-post-actions-nochroot fi if [ -e /tmp/.kylin-post-actions-nochroot ];then /bin/bash -x /tmp/.kylin-post-actions-nochroot &> $ANA_INSTALL_PATH/var/log/.kylin-post-actions-nochroot.log fi %end %post systemctl disable systemd-networkd-wait-online.service systemctl disable multipathd.service ### do kylin post action if [ -e /bin/.kylin-post-actions ];then /bin/bash -x /bin/.kylin-post-actions &> /var/log/.kylin-post-actions.log fi %end %packages @^minimal-environment %end # Keyboard layouts keyboard --xlayouts='us' # System language lang en_US.UTF-8 # Network information network --hostname=localhost.localdomain # Use CDROM installation media cdrom # Run the Setup Agent on first boot firstboot --enable # System services services --enabled="chronyd" ignoredisk --only-use=sda # Partition clearing information clearpart --none --initlabel # Disk partitioning information #part swap --fstype="swap" --ondisk=sda --size=2046 part swap --fstype="swap" --ondisk=sda --size=1024 part /boot/efi --fstype="efi" --ondisk=sda --size=1024 --fsoptions="umask=0077,shortname=winnt" #part / --fstype="xfs" --ondisk=sda --size=37888 part / --fstype="xfs" --ondisk=sda --size=7000 # System timezone timezone Asia/Shanghai --utc user --groups=wheel --name=kylin --gecos="Kylin" %addon com_redhat_kdump --enable --reserve-mb='1024M' %end %anaconda pwpolicy root --minlen=8 --minquality=1 --strict --nochanges --notempty pwpolicy user --minlen=8 --minquality=1 --strict --nochanges --emptyok pwpolicy luks --minlen=8 --minquality=1 --strict --nochanges --notempty %end ``` Any hints/tips/docs are highly appreciated! Thanks
1
answers
0
votes
33
views
AWS
asked 2 months ago
I've been trying to connect an ec2 machine from aws to my localhost (WSL on windows) docker swarmer cluster, but i keep getting displayerd : Error response from daemon: Timeout was reached before node joined. The attempt to join the swarm will continue in the background. Use the "docker info" command to see the current swarm status of your node." and the ec2 is not being added as a node (even if later I try to add it again, it says that it is already part of a cluster, on my localhost it does not appear added). **What I've been tried:** Open the doors 2377, 7946 and 4789 (required by docker) on my wsl and ec2. approved all traffic to all ports on my ec2 firewall. desable my windows firewall (Tried to init a windows cluster to add ec2, but did not worked too. **Aditional information:** to open the doors on my wsl/ec2 I mainly used ufw and telnet. I was able to connect my windows docker to my wsl cluster. I'm being able to ping my ec2 ipv4 adress from mylocalhost, but not my localhost ip from ec2. Any suggestions and solutions are welcome, i'm seriously HOURS in this, any progress will make me happy Systems: I'm using ubuntu 18-04 on wsl and ecs, and windows 11 ![a print of my ec2 security firewall](/media/postImages/original/IMUPeb2tCDQe653UdL_rAMjQ)
1
answers
0
votes
18
views
asked 2 months ago
Firing up new RHEL 9 EC2 ARM64 instance, and immediately trying to do a yum update and it can't. It appears the BaseOS is out of sync (older) with the updated Appstream repo. None of my 12 Reserved Instances, running RHEL9, can yum update either. If I disable BaseOS, it doesn't complain. I can't contact RHEL, since RedHAT says AWS handles RedHAT support. I've tried US-EAST-1, US-EAST-2, and US-WEST-2. The Appstream Repo, which provides all of the -devel rpms, has newer, updated rpms, which is complaining about older rpms in the BaseOS. As you can see it wants differing packages for -devel and base versions, which can't happen. Please fix. Thanks! Red Hat Enterprise Linux 9 for aarch64 - AppStream from RHUI (RPMs) 27 MB/s | 13 MB 00:00 Red Hat Enterprise Linux 9 for aarch64 - BaseOS from RHUI (RPMs) 40 MB/s | 6.0 MB 00:00 Red Hat Enterprise Linux 9 Client Configuration 18 kB/s | 1.8 kB 00:00 Error: Problem 1: package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed - cannot install both authselect-1.2.5-2.el9_1.aarch64 and authselect-1.2.5-1.el9.aarch64 - cannot install the best update candidate for package authselect-compat-1.2.5-1.el9.aarch64 - cannot install the best update candidate for package authselect-1.2.5-1.el9.aarch64 Problem 2: package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed - cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64 - cannot install the best update candidate for package glibc-devel-2.34-40.el9.aarch64 - cannot install the best update candidate for package glibc-2.34-40.el9.aarch64 Problem 3: package zlib-devel-1.2.11-34.el9.aarch64 requires zlib(aarch-64) = 1.2.11-34.el9, but none of the providers can be installed - cannot install both zlib-1.2.11-35.el9_1.aarch64 and zlib-1.2.11-34.el9.aarch64 - cannot install the best update candidate for package zlib-devel-1.2.11-34.el9.aarch64 - cannot install the best update candidate for package zlib-1.2.11-34.el9.aarch64 Problem 4: package libxcrypt-devel-4.4.18-3.el9.aarch64 requires glibc-devel(aarch-64) >= 2.27, but none of the providers can be installed - package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed - package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed - package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed - package glibc-2.34-40.el9.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-40.el9 if redhat-rpm-config), but none of the providers can be installed - package glibc-2.34-28.el9_0.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0 if redhat-rpm-config), but none of the providers can be installed - package glibc-2.34-28.el9_0.2.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0.2 if redhat-rpm-config), but none of the providers can be installed - cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-40.el9.aarch64 - cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.aarch64 - cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.2.aarch64 - cannot install the best update candidate for package redhat-rpm-config-196-1.el9.noarch - cannot install the best update candidate for package libxcrypt-devel-4.4.18-3.el9.aarch64 - cannot install the best update candidate for package glibc-gconv-extra-2.34-40.el9.aarch64 Problem 5: problem with installed package authselect-compat-1.2.5-1.el9.aarch64 - package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed - package authselect-1.2.5-1.el9.aarch64 requires authselect-libs(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed - cannot install both authselect-libs-1.2.5-2.el9_1.aarch64 and authselect-libs-1.2.5-1.el9.aarch64 - cannot install the best update candidate for package authselect-libs-1.2.5-1.el9.aarch64 Problem 6: package gcc-11.3.1-2.1.el9.aarch64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed - package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed - package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed - package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed - package glibc-2.34-40.el9.aarch64 requires glibc-common = 2.34-40.el9, but none of the providers can be installed - package glibc-2.34-28.el9_0.aarch64 requires glibc-common = 2.34-28.el9_0, but none of the providers can be installed - package glibc-2.34-28.el9_0.2.aarch64 requires glibc-common = 2.34-28.el9_0.2, but none of the providers can be installed - cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-40.el9.aarch64 - cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.aarch64 - cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.2.aarch64 - cannot install the best update candidate for package glibc-common-2.34-40.el9.aarch64 - cannot install the best update candidate for package gcc-11.3.1-2.1.el9.aarch64 Problem 7: problem with installed package glibc-devel-2.34-40.el9.aarch64 - package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed - cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64 - package glibc-langpack-en-2.34-40.el9_1.1.aarch64 requires glibc = 2.34-40.el9_1.1, but none of the providers can be installed - cannot install the best update candidate for package glibc-langpack-en-2.34-40.el9.aarch64 You can even take the AMI Image directly from RHEL, https://access.redhat.com/solutions/15356 and try and do a yum update, on install and get: [root@ip-172-30-3-97 ~]# yum update Updating Subscription Management repositories. Unable to read consumer identity This system is not registered with an entitlement server. You can use subscription-manager to register. Red Hat Enterprise Linux 9 for aarch64 - AppStream from RHUI (RPMs) 65 MB/s | 13 MB 00:00 Red Hat Enterprise Linux 9 for aarch64 - BaseOS from RHUI (RPMs) 35 MB/s | 6.0 MB 00:00 Red Hat Enterprise Linux 9 Client Configuration 19 kB/s | 1.8 kB 00:00 Error: Problem 1: package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed cannot install both authselect-1.2.5-2.el9_1.aarch64 and authselect-1.2.5-1.el9.aarch64 cannot install the best update candidate for package authselect-compat-1.2.3-7.el9.aarch64 cannot install the best update candidate for package authselect-1.2.3-7.el9.aarch64 Problem 2: problem with installed package authselect-compat-1.2.3-7.el9.aarch64 package authselect-compat-1.2.3-7.el9.aarch64 requires authselect(aarch-64) = 1.2.3-7.el9, but none of the providers can be installed package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed package authselect-1.2.3-7.el9.aarch64 requires authselect-libs(aarch-64) = 1.2.3-7.el9, but none of the providers can be installed package authselect-1.2.5-1.el9.aarch64 requires authselect-libs(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed cannot install both authselect-libs-1.2.5-2.el9_1.aarch64 and authselect-libs-1.2.3-7.el9.aarch64 cannot install both authselect-libs-1.2.5-2.el9_1.aarch64 and authselect-libs-1.2.5-1.el9.aarch64 cannot install the best update candidate for package authselect-libs-1.2.3-7.el9.aarch64 (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages) If you add --allowerasing, and let it remove authselect-compat on this initial update, then do a: yum group install "development tools", and let it install all the -devel rpms, now you're in for a world of hurt. Any yum updates after that, and with repos out of sync, yum can't update: [root@ip-172-30-3-97 ~]# yum update Updating Subscription Management repositories. Unable to read consumer identity This system is not registered with an entitlement server. You can use subscription-manager to register. Last metadata expiration check: 0:03:07 ago on Thu 26 Jan 2023 09:17:10 PM UTC. Error: Problem 1: package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64 cannot install the best update candidate for package glibc-devel-2.34-40.el9.aarch64 cannot install the best update candidate for package glibc-2.34-40.el9.aarch64 Problem 2: package zlib-devel-1.2.11-34.el9.aarch64 requires zlib(aarch-64) = 1.2.11-34.el9, but none of the providers can be installed cannot install both zlib-1.2.11-35.el9_1.aarch64 and zlib-1.2.11-34.el9.aarch64 cannot install the best update candidate for package zlib-devel-1.2.11-34.el9.aarch64 cannot install the best update candidate for package zlib-1.2.11-34.el9.aarch64 Problem 3: package libxcrypt-devel-4.4.18-3.el9.aarch64 requires glibc-devel(aarch-64) >= 2.27, but none of the providers can be installed package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed package glibc-2.34-40.el9.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-40.el9 if redhat-rpm-config), but none of the providers can be installed package glibc-2.34-28.el9_0.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0 if redhat-rpm-config), but none of the providers can be installed package glibc-2.34-28.el9_0.2.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0.2 if redhat-rpm-config), but none of the providers can be installed cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-40.el9.aarch64 cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.aarch64 cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.2.aarch64 cannot install the best update candidate for package redhat-rpm-config-196-1.el9.noarch cannot install the best update candidate for package libxcrypt-devel-4.4.18-3.el9.aarch64 cannot install the best update candidate for package glibc-gconv-extra-2.34-40.el9.aarch64 Problem 4: package gcc-11.3.1-2.1.el9.aarch64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed package glibc-2.34-40.el9.aarch64 requires glibc-common = 2.34-40.el9, but none of the providers can be installed package glibc-2.34-28.el9_0.aarch64 requires glibc-common = 2.34-28.el9_0, but none of the providers can be installed package glibc-2.34-28.el9_0.2.aarch64 requires glibc-common = 2.34-28.el9_0.2, but none of the providers can be installed cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-40.el9.aarch64 cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.aarch64 cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.2.aarch64 cannot install the best update candidate for package glibc-common-2.34-40.el9.aarch64 cannot install the best update candidate for package gcc-11.3.1-2.1.el9.aarch64 Problem 5: problem with installed package glibc-devel-2.34-40.el9.aarch64 package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64 package glibc-langpack-en-2.34-40.el9_1.1.aarch64 requires glibc = 2.34-40.el9_1.1, but none of the providers can be installed cannot install the best update candidate for package glibc-langpack-en-2.34-40.el9.aarch64 Problem 6: package annobin-10.73-3.el9.aarch64 requires (gcc >= 11 with gcc < 12), but none of the providers can be installed package gcc-11.3.1-2.1.el9.aarch64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64 cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-28.el9_0.aarch64 cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-28.el9_0.2.aarch64 package gcc-11.2.1-9.4.el9.aarch64 requires cpp = 11.2.1-9.4.el9, but none of the providers can be installed package glibc-minimal-langpack-2.34-40.el9_1.1.aarch64 requires glibc = 2.34-40.el9_1.1, but none of the providers can be installed cannot install both cpp-11.2.1-9.4.el9.aarch64 and cpp-11.3.1-2.1.el9.aarch64 cannot install the best update candidate for package glibc-minimal-langpack-2.34-40.el9.aarch64 cannot install the best update candidate for package cpp-11.3.1-2.1.el9.aarch64 cannot install the best update candidate for package annobin-10.73-3.el9.aarch64 (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest'
1
answers
0
votes
36
views
asked 2 months ago
I'm trying to setup an LaTeX process that will take a LaTeX file and convert it to a PDF. I have found the yum repositories for texlive and texline-latex, but I have no found an article on how to set these up on an EC2 Linex2 instance.
0
answers
0
votes
4
views
Whit
asked 2 months ago
Is it possible to schedule hibernation of an instance just like Start/Stop? Am I reading correctly that hibernate is a keyword in DynamoDB https://docs.aws.amazon.com/solutions/latest/instance-scheduler-on-aws/components.html If so, how do I create a schedule? BTW, my EC2 instance works fine and I can manually hibernate it at will. Thank you MN
1
answers
0
votes
33
views
asked 2 months ago