By using AWS re:Post, you agree to the Terms of Use

Unanswered Questions tagged with Amazon Cognito

Sort by most recent

Browse through the questions and answers listed below or filter and sort to narrow down your results.

Why am I getting a 401 error when signing in from Cognito's hosted UI?

Thank you for all your help. I would appreciate it if you could tell me if you know about the following events. 【Question】 Why do I get a 401 Authorization Required error when signing in from Cognito's hosted UI when integrating Cognito and ALB? 【Specific situation】 We have verified the integration between Cognito and ALB following the procedure in the following blog. [1] [1] I added authentication with Cognito to an environment where content is delivered with EC2 and ALB | DevelopersIO https://dev.classmethod.jp/articles/cognito-alb-secret/ The procedure itself was all successful, but I had a personal concern. That is, what would be the behavior if I signed in from Cognito's hosted UI instead of accessing the ALB's domain? I actually created a user in Cognito and clicked the "View Hosted UI" button from the Cognito console. The sign-in page appeared, so I signed in as a Cognito user and changed my password. However, the screen that appeared after the password change showed only 401 Authorization Required. After that, I tried accessing the ALB domain, and this time the EC2 page behind ALB was displayed correctly. This does not happen when signing in at the ALB domain, but only when accessing from the Cognito hosted UI. [Regarding the attached file] ・401 Authorization Required screen ![Enter image description here](/media/postImages/original/IM_hKXXqbkSBunEFZ80niBxw) ・Button to display Cognito's hosted UI ![Enter image description here](/media/postImages/original/IMyY2Bm5mDT1aj04CBHoqi1Q) ・Allowed callback URLs ![Enter image description here](/media/postImages/original/IMt25vrVgRR0-2F43bfqBvzw) We would be grateful if you could enlighten us on the above.
0
answers
0
votes
13
views
profile picture
asked 3 days ago

AppSync can't connect to Cognito in eu-north-1

Hello AWS re:Post I have an AppSync API and a Cognito userpool in the region eu-north-1. Until last week, I've been authenticating my queries with the cognito pool. One day last week, I wake up and it doesn't work in the AppSync GUI. When I go to the API settings, it doesn't show any userpools for the selected region (eu-north-1). If I select another region and switch back to eu-north-1, I get an error message saying "Error: Network Failure" as seen on below screenshot: ![Enter image description here](/media/postImages/original/IMsi-hCA_NQ3KYeicLXYkQKw) I've tried the following things so far: Make a new cognito pool in eu-north-1 -> Doesn't work, can't see new pool either Make a new cognito pool in another region -> Works, can see this pool, but my stack and domains are set up on eu-north-1 Make a new AppSync API in eu-north-1 -> Doesn't work, still same error Make new AppSync API in another region -> Doesn't work, still same error This error has me stumbled. What can I possibly be doing wrong to get this result? Is there a connectivity problem between AppSync and Cognito on eu-north-1? At first (after the GUI problem appeared), I was still able to make queries to the API from external programs, authenticating with the cognito pool, but this obviously stopped working as soon as I started testing with other Cognito Pools since I have no way of selecting the original again. Let me know if I can provide any other relevant information Best regards, Alexander
0
answers
0
votes
29
views
asked a month ago