Unanswered Questions tagged with AWS DataSync

Content language: English

Sort by most recent

Browse through the questions and answers listed below or filter and sort to narrow down your results.

  • 1
  • 12 / page

Copy Data from EFS to EFS in Same Account & Region

Hi Everyone, Testing what should be a simple use case in DataSync. For the moment, just using the console to setup two EFS locations (source and destination) and one task (unscheduled) to copy all data (from task path) from source to destination. Since these two file systems operate in the same region and the same account, I think (hope) I can use a serverless setup that does not require (for example) NFS to EFS with an agent, etc. I have setup only these resources in DataSync: - Location: Source EFS in us-east-1 with correct subnet and SG that has "/" as the mount path - Location: Destination EFS location in us-east-1 with correct subnet and SG that has "/" as the mount path - Task: in us-east-1 that configures source and destination and mostly uses default settings, though has this notable config: Data transfer configuration > Specific files and folders > Include patterns > /home/user/subfolder/ Everything looks good and I am able to manually start the task, which moves through the Task status: *Launching* and then shows *Success*, but I see that only 1 file is transferred (there are 122 files on the source file system that I am attempting to copy). Looking at the destination EC2 instance, I see only a new hidden directory named: `.aws-datasync` created in `/home/user/subfolder/`. I thought perhaps my include pattern was slightly off and so tested these: - /home/user/subfolder/ - /home/user/subfolder - /home/user/subfolder/* - /home/user/subfolder* but the results are always the same: task success but no files (except the hidden dir) transferred ... Any help is much appreciated. Ben
0
answers
0
votes
8
views
bwmills
asked 7 hours ago

Amplify datastore stopped to sync

I am using the aws-amplify API to manipulate the datastore. Everything was going fine and all queries were running successfully until it stopped to work suddenly. In my case i am building an NPM package to wrap aws-amplify functionality with node and typescript. And another developer is using the package to build a native app with react-native. So when i implement new functions i test it locally with ts-node, something like DataStore.query or DataStore.Save ...etc, and the other developer is testing with expo after install the last package release i have done. Once we had a problem saying: ``` [WARN] 04:14.549 DataStore, Object { "cause": Object { "error": Object { "errors": Array [ Object { "message": "Connection failed: {\"errors\":{\"errorType\":\"MaxSubscriptionsReachedError\",\"message\":\"Max number of 100 subscriptions reached\"}}", }, ], }, ``` When it's happened, I tried to run queries locally and it work good with a warning: ``` [WARN] 33:35.743 DataStore - Realtime disabled when in a server-side environment ``` So we thought it is cache problem or something. But now nothing works at all in the dataStore. If i am trying to run code locally with ts-node, the console freeze and never comeback. For example if i do: `await DataStore.query(AccountDetails, "a6603b3e-4ae1-4f6c-9360-bd82fe01dd0d")` the console will freeze with the warning message: ![Enter image description here](https://repost.aws/media/postImages/original/IMdp4AdBO9SAuBC8xX8R_rtg) We tried to fix appSync and subscriptions but it is not working at all. Cognito user pool works good, S3 also good, only datastore is sad :( ``` // How we configure amplify this.awsExports = Amplify.configure({ ...awsConfig }); // How we import Datastore import {DataStore} from "@aws-amplify/datastore"; // Our dependencies "dependencies": { "@aws-amplify/core": "^4.6.0", "@aws-amplify/datastore": "^3.12.4", "@react-native-async-storage/async-storage": "^1.17.4", "@react-native-community/netinfo": "^8.3.0", "@types/amplify": "^1.1.25", "algoliasearch": "^4.14.1", "aws-amplify": "^4.3.29", "aws-amplify-react-native": "^6.0.5", "aws-sdk": "^2.1142.0", "aws-sdk-mock": "^5.7.0", "eslint-plugin-jsdoc": "^39.2.9", "mustache": "^4.2.0" } ``` Please any one can help?
0
answers
0
votes
62
views
asked 4 months ago
  • 1
  • 12 / page