MWAA Metadatabase not initialized - log, dag, triggers relations do not exist


we have created the MWAA env, ECR, SUBNETs, private SGs, VPC - we see NICs attached to the SG

access via UI is given - we can login and open UI via web browser.

on /home access we see an Ooops screen browsing other menus (i.e. Security, Docs) work - all the other Dags, Admin, Browse menus result in an Ooops

no log other than webserver showing some feedback:

on /home : psycopg2.errors.UndefinedTable: relation "dag" does not exist

how can one run a db init ? we have tried it using via REST API ( - which works for certain commands but the db init returns with "TypeError: 'int' object is not iterable"

any help is welcome

what is the need of the security group rules (egres, ingres) ?

1 回答

we fixed it in the end while going through the aws mwaa exampl line by line - the problem we found missing in our setup was a self pointing rule on the mwaa security group

we have re-created the env and all works as designed

已回答 2 年前

您未登录。 登录 发布回答。